1. Issues with the game?
    Check the Known Issues list before reporting!

    Dismiss Notice

0.24 Discussion thread

Discussion in 'General Discussion' started by Leeloo, Dec 2, 2021.

Thread Status:
Not open for further replies.
  1. DaddelZeit

    DaddelZeit
    Expand Collapse

    Joined:
    Jul 17, 2019
    Messages:
    3,039
    Try to reset your postfx settings (In the Graphics settings, might have to enable advanced functionality)
     
    • Like Like x 1
  2. TechMechanic

    TechMechanic
    Expand Collapse

    Joined:
    Nov 22, 2017
    Messages:
    601
  3. EruptionTyphlosion

    EruptionTyphlosion
    Expand Collapse

    Joined:
    Sep 24, 2016
    Messages:
    2,921
    The announcement on the top of the forums that says to "check the known issues list" seems to link to the front page of the site as opposed to the list.
     
  4. SamParker772

    SamParker772
    Expand Collapse

    Joined:
    May 27, 2020
    Messages:
    49
    (Tried in safe mode) the water is very buggy (only tried on small island, usa)
     

    Attached Files:

  5. Foxle_Fox

    Foxle_Fox
    Expand Collapse

    Joined:
    Dec 16, 2021
    Messages:
    83
    If you use the D-Series flatbed and put on the chrome roll-bar, it falls off without any effort like it's not connected.

    It does not happen with the black roll-bar.
     

    Attached Files:

    • flatbedchrome.png
    • flatbedblack.png
    • Agree Agree x 1
  6. RobloxFan2

    RobloxFan2
    Expand Collapse

    Joined:
    Aug 28, 2019
    Messages:
    745
    yeah upload_2021-12-16_18-19-53.png
     
  7. Covalence

    Covalence
    Expand Collapse

    Joined:
    Jul 3, 2021
    Messages:
    25
    Delete any BeamMP files from your game folder, it causes this to happen in 0.24 even if you disable it.
     
  8. Yash_gamin144

    Yash_gamin144
    Expand Collapse

    Joined:
    Apr 24, 2021
    Messages:
    1,574
    Jeez dats alot of bugs and glitches..
     
  9. Covalence

    Covalence
    Expand Collapse

    Joined:
    Jul 3, 2021
    Messages:
    25
    I saw there was another update on steam, downloaded it and so far:
    • the AI doesn't seem to respawn cars nearly as much as it used to (it used to feel fine with 6 cars but now the roads are mostly empty), it keeps randomly steering into barriers before reversing, it drifts across lanes, selecting Flee/Chase AI doesn't work on all newly spawned cars, and if you select Spawn Normal after Spawn Police it stops working altogether
    • you can't edit the UI as it gets reset to default every time the menu opens (edit: went away on its own)
    • UI elements not hidden in cockpit cover the overview UI when you start a scenario
    • the FPS tanks after the 1st delivery in Garage to Garage Delivery, for me it goes from 40fps to 15 but it goes back to 40 while the game is paused
    • selecting something in the radial menu closes it (but not the regular menu) and you have to close/reopen the menu to get it back
    • some settings don't save, such as the grass/tire tracks amount
    However I did notice it now scales the menu UI much better at lower resolutions, especially in the vehicle selector.
     
    #1009 Covalence, Dec 17, 2021
    Last edited: Dec 21, 2021
  10. A Russian Pineapple

    A Russian Pineapple
    Expand Collapse

    Joined:
    Apr 27, 2018
    Messages:
    51
    While I love the new updated gauges on the LeGran, it seems the tachometer labeling has become wrong again.
    It should say RPM x 100, not x 1000. Make sure to change it on both the lit and unlit gauge textures this time! :)
    Is the tachometer lighting supposed to be really dim near the '20' mark?
    upload_2021-12-17_0-16-17.png

    Also "couch" is misspelled as "coush" in the skin selector.
    upload_2021-12-17_0-19-47.png
     
    • Agree Agree x 6
  11. JlnPrssnr

    JlnPrssnr
    Expand Collapse

    Joined:
    Jun 15, 2016
    Messages:
    25
    I'd like to un-report a bug that I never got around to report, it's now possible in .24 to map the right stick on controller to handbrake, by inverting the axis and setting deadzones so center is no handbrake and stick pulled down is full handbrake :)
     
  12. Agent_Y

    Agent_Y
    Expand Collapse

    Joined:
    Jul 10, 2020
    Messages:
    6,813
    That's intentional, supposed to mock people who sell used couches trying to pass them as "almost" brand new and can't spell lol
     
    • Like Like x 2
    • Agree Agree x 2
  13. ZZ04

    ZZ04
    Expand Collapse

    Joined:
    Dec 6, 2021
    Messages:
    3

    I'm still having the traffic issue as well. If I set traffic to Chase or Random, traffic seems to revert back to normal as new traffic cars spawn.
     
  14. McBeamer94

    McBeamer94
    Expand Collapse

    Joined:
    Jan 4, 2019
    Messages:
    1,096
    Has anyone noticed that the Chrome versions of the DutyPro-L/-S/-XL and the Gavril 423S center caps actually have a flat, off-white look instead of a chrome one? They don't reflect the light in the way chrome should do, as we can clearly see on the Alder Special 423 wheels (on which the Gavril 423S center caps clip) and even on the Heavy-Duty Steel wheels and the Gavril HD350 Steel ones (on which the DutyPro-XL center caps clip). The flat off-white finish of these Chrome caps just looks wrong and clashes with the chrome finish of these wheels.
    I mean, the Gavril HD350 Steel wheels and the Heavy Duty Steel wheels have a nice glossy chrome finish even though they don't say it on their names in the Parts Selector, and the DutyPro-L/-S/-XL (as well as the Gavril 423S) chrome caps, although they say they're chromed, actually aren't or at least they don't look like they are!
     
  15. The Gas Station

    The Gas Station
    Expand Collapse

    Joined:
    Jul 14, 2016
    Messages:
    258
    I got a bug to report- when walking around out of your car, then pressing tab to switch cars, a doppelganger is created. this leads to very interesting unintentional behaviour, and allows some shenanigans that should not be possible:


    But I'm also totally cool with this becoming a feature in-game. Not sure if it maintains the age-restriction of beamng however.


    I really like the map overview and waypoint system, I think it was very well put together.
    20211217192631_1.jpg
    This is pretty beautiful!

    Also, the mission concept is really nice and has lots of potential, I really can't wait to see what it turns into! Are there any plans for integrating scenarios into the mission system? And, any plans on keeping existing damage/fuel levels when quick-traveling, or when finishing a mission?

    20211217193235_2.jpg
    Minor bug in the Containerland mission/quickrace. The race is playable, only the car starts slightly underground.

    20211217200957_1.jpg
    Some quickrace previews don't show up properly (because of mismatched photo size?)

    As a side note - I really didn't like how this update messed up the controls setup I had, I had to reconfigure quite a bit of keys. But I guess it was inevitable. Also, I'm really looking forward to more UI development, I know it's just at the start of it's development, but it isn't responsive at all on my slowly-aging computer, despite the game itself running really quite well on most maps, at decent rendering settings!
     
    • Like Like x 1
  16. glen

    glen
    Expand Collapse

    Joined:
    Mar 7, 2017
    Messages:
    319
    I understand that the known issues say that the “show custom vehicles in vehicle selector” does not work, but I’m confused if that means that they don’t show up, of if they are stuck in the vehicle selector. For me, no matter what I do, the custom vehicles are stuck in the selector.
     
  17. Diamondback

    Diamondback
    Expand Collapse
    Vehicle Systems Lead
    BeamNG Team

    Joined:
    Apr 8, 2014
    Messages:
    1,840
    Not a bug, this is the intended behavior as-designed. :)
     
    • Like Like x 4
    • Agree Agree x 3
  18. PainyTOXA

    PainyTOXA
    Expand Collapse

    Joined:
    Sep 29, 2013
    Messages:
    86
    I have one interesting bug that occurs for me only on Italy "Garage Delivery" scenario, and only when I've already done one scenario and am doing the next one.

    Basically, the game kinda... hiccups a bit? every second, and I believe it is exactly every second, until I drive some distance from the initial spawn point - and I don't see any AI cars unless I drive away a bit from the spawn, then they start spawning around me and the hiccups disappear.

    What I think happens (and please note that I actually have no clue how it works, I'm trying to guesstimate it from bits of knowledge I have in coding):
    There's some variable that says "Here's player's car right now", and it updates every X distance from the previous position, or every "chunk of land" if we're speaking minecraft terms.
    So I believe when you end your scenario in a "chunk Y" - in this example, in the Aeroporto - when you click "Next Delivery" and spawned in a "chunk Z" somewhere far away (say, on the coast), that exact "Player is in this chunk" variable sometimes is not updated, and the AI cars spawn somewhere around the Original point in Aeroporto.
    These cars spawn in "chunk Y", then detect that they're actually reaaaally far away from your actual position (which is another variable? GPS position, I assume?), then try to respawn - but not at "Player's Position" variable but somewhere in "chunk Y", and are repeating it exactly every one second. Thus the lag.
    And when you drive away for a short while this "Player is in this chunk" variable updates properly and cars start to appear nearby.
    I think the "update variable" routine triggers when you are actually changing "chunks", and for some reason does not update sometimes when you've been forcefully moved to another position. Might be worth testing with standard AIs and Teleports, or with hacking "Garage Delivery" with adding teleports? No clue.

    This does not happen often, but does sometimes. I'm glad I have a fairly powerful rig and have limited the cars to max of 8, otherwise the hiccups could've been way worse and way more noticeable. Though I think this also happens to other people, but it takes some knowledge to tie (assumed) car respawning timeout and exact 1 second lags, especially if it disappears when you drive for a bit, which might take 5 seconds of driving.

    By the way - if that is what actually happens, I'm really glad there's hardcoded timeout for cars respawn, otherwise they'll start spawning every time their routines check for distance, and that might be like 4 thousand times a second? 4 million times a second? Damn.

    P.S. Yes, I like to give detailed bug reports x)
     
    #1018 PainyTOXA, Dec 18, 2021
    Last edited: Dec 18, 2021
  19. vmlinuz

    vmlinuz
    Expand Collapse

    Joined:
    Mar 2, 2014
    Messages:
    2,117
    I'm seeing messed up textures on the LeGran's badges, not sure if anyone else is or if it's a mod conflict but I have cleared my cache multiple times and uninstalled all mods
     
  20. Foxle_Fox

    Foxle_Fox
    Expand Collapse

    Joined:
    Dec 16, 2021
    Messages:
    83
    I'm assuming this will be fixed with the coming update, but just incase, all the available exhaust pipes for the Bolide don't have openings. They do make exhaust gasses though.

    Pretty sure it's already considered and is fixed for the update, but just in case :D
     

    Attached Files:

    • exhaustbolide.png
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice