1. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    Solutions and more information may already be available.

Ai Behaving Oddly - No Avoidance to Other Vehicles & Terrain

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by Mr_StickShift, Sep 11, 2019.

Tags:
  1. Mr_StickShift

    Mr_StickShift
    Expand Collapse

    Joined:
    May 11, 2019
    Messages:
    41
    After the latest update (0.17.1 [Third Hotfix]) whenever I use the AI "Traffic" Mode, the AI seems to be unaware of other vehicles (including the player) - Before the most recent hotfix, the AI was fine, stopped, avoided and drove pretty well.

    The issue now is that whenever I use it, the AI crash into other AI and also the Player's Vehicle - Where as they should stop when the route is blocked or try to go around it.

    I also tried to park at the side of the road where the AI used to go around you - Now they just plow into the back of me.
     
    • Agree Agree x 3
  2. Superchu Frostbite

    Superchu Frostbite
    Expand Collapse

    Joined:
    Feb 8, 2016
    Messages:
    236
    Can confirm, the AI is running around as if the awareness is off. They just sorta yeet themselves into parked cars, making fender benders into crippling 5 car pileups. This happened after I (White Pessima) parked in the opposing lane. The yellow K just sorta ran into me at 20, followed by all the rest, which pushed me back from the impact because I wasn't holding the brake. The cop even did burnouts while stupidly pushing against parked cars with their flashers on. Interestingly, they seemed to see the yellow K and tried to cross into oncoming to go around it, but they hit it anyway. 20190911115546_1.jpg
    Side note, this all happened in like 2 minutes.
    EDIT: I don't know my ETKs very well.
     
    • Agree Agree x 3
  3. Mr_StickShift

    Mr_StickShift
    Expand Collapse

    Joined:
    May 11, 2019
    Messages:
    41
    I think it is where they tried to fix the AI having issues in the previous update and they seemed to have changed a code that causes the avoidance - Annoying really, since that's the best part of the "Traffic"
     
    • Agree Agree x 2
  4. Jono100000

    Jono100000
    Expand Collapse

    Joined:
    Aug 11, 2013
    Messages:
    17
    I am not sure if you guys have tested this but i have even on safe mode where the AI cops do not chase you even if you crash in to them. They are acting like normal AI i am not sure if the "Third hotfix" caused an issue with the AI.. it was working on the 0.17.1 update
     
  5. Mr_StickShift

    Mr_StickShift
    Expand Collapse

    Joined:
    May 11, 2019
    Messages:
    41
    Yes - I did try it in safe mode - One of the staff members did find the game pulling fatal errors when loading the AI. I saw that the same issue is still occurring, hopefully, a hotfix will be released soon, as it's affecting my play of the game when I like to drive with the AI.
     
  6. Jono100000

    Jono100000
    Expand Collapse

    Joined:
    Aug 11, 2013
    Messages:
    17
    Yeah i thought i was going crazy with the AI cause i tested it before the hot fix was pushed and it worked flawlessly and now when i tested it i thought something happen or a mod was conflicting but i hope they pushed one quick i kinda want to try and do a police chase properly
     
  7. XxTomCoolpopxX

    XxTomCoolpopxX
    Expand Collapse

    Joined:
    May 7, 2017
    Messages:
    5
    Yep, same problem here, hopefully if we bring enough attention to the problem the devs will release a hotfix soon
     
  8. Nadeox1

    Nadeox1
    Expand Collapse
    BeamNG.Support
    Staff Member

    Joined:
    Aug 5, 2012
    Messages:
    13,382
    • Like Like x 2
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice