AMD software crashed during an update

Discussion in 'Computer Hardware' started by ChickenZed, Jul 22, 2019.

  1. ChickenZed

    Expand Collapse

    May 19, 2019
    I know this is really off topic from BeamNG, but this really spooked me. Here's the story: I'm updating my AMD radeon software. Everything is going fine, until it freezes at about 50%. I wait for about a minute... Boom. Error. The error code is 1603, which is typically associated with corrupted files, which I think I would have noticed earlier. Now when I start Radeon Software it gives me the following message: "No AMD graphics driver is installed, or the AMD driver is not functioning properly. Please install the AMD driver appropriate for your AMD hardware." Okay, just reinstall the drivers and software right? here's the issue: It cant find my GPU (Radeon Pro 570, typically found in the 2017 27-inch low-end iMac. Here's the other issue: Im not a Windows user and have no idea on how to safely uninstall my drivers. My OS is Windows 10 build 1903. GPU is (as mentioned) a Radeon Pro 570.
    Edit: 4 months later I resolved the issue. I just ran the driver installer and it worked. Last time I tried running it, it failed to recognize my GPU.
    #1 ChickenZed, Jul 22, 2019
    Last edited: Apr 2, 2020
  2. alexelcaza

    Expand Collapse

    Jun 28, 2015
  3. A Turbocharged Turbocharger

    A Turbocharged Turbocharger
    Expand Collapse

    Nov 26, 2018
    This is probably going to get deleted, but why are you gaming on an iMac?
    --- Post updated ---
    I honestly doubt a gpu like that even has drivers, but just use the drivers for your card's rx equivalent to try and fix the problem
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice