1. Stuck, Having problems with creating your mod? Let us help you: Mod Support

Solved custom bumper not showing up on car

Discussion in 'Mod Support' started by ThomasPlaysOfficial, Jul 25, 2018.

Tags:
  1. ThomasPlaysOfficial

    ThomasPlaysOfficial
    Expand Collapse

    Joined:
    Apr 8, 2017
    Messages:
    144
    So, basically, i'll put it this way

    i suck at modding

    now with that out of the way, i wanted to make a custom bumper for the roamer for my UK Police Pack so it would be unique and different and not just skin configs with default parts (which i know people dislike as it is low effort). i have it modelled, and textured, and i did ctrl + a in blender. I was going to try jbeaming it after i tested how it looked ingame but the only problem is, when i select my custom bumper, it just appears as a default bumper. I had a similar issue (ironically also with the roamer) about a year ago and i followed steps shown there but it still doesnt work. i've included some photos and the mod file if anyone wants to provide assistance.
    i should really stop trying to make mods, now its literally like i'm asking people to spoon feed me assistance when i make stuff

    bumperinblendyblend.png ]
    (bumper model in blender)


    ybumpernowrok.png

    (when i select my bumper)

    any help would be very appreciated
     

    Attached Files:

  2. fufsgfen

    fufsgfen
    Expand Collapse

    Joined:
    Jan 10, 2017
    Messages:
    6,743
    You have mateirals.cs instead of materials.cs

    Your mapTo is mapTo = "black"; however your bumper in blender has material name of black_001, mapTo should match exactly to material name in Blender.

    Your flexbody is roamer_bumper_F, that should be same as name of your object in Blender roamer_bumper_FA.

    Those were errors what I quickly spotted.
     
    • Agree Agree x 1
  3. ThomasPlaysOfficial

    ThomasPlaysOfficial
    Expand Collapse

    Joined:
    Apr 8, 2017
    Messages:
    144
    thanks for some error spotting, but it still doesnt work :|
     
  4. fufsgfen

    fufsgfen
    Expand Collapse

    Joined:
    Jan 10, 2017
    Messages:
    6,743
    What does not work, what have you changed and to what, when you open console (~ key) is there any errors?
     
  5. ThomasPlaysOfficial

    ThomasPlaysOfficial
    Expand Collapse

    Joined:
    Apr 8, 2017
    Messages:
    144
    basically, it still doesnt appear. i changed the materials file to the correct name, changed the material name in blender and changed the flexbodys.

    i attached every error in the console from spawning the roamer and putting my mod onto it. the rest is just "lua.v.print" which is probably game code
    20180727103936_1.jpg
     
  6. fufsgfen

    fufsgfen
    Expand Collapse

    Joined:
    Jan 10, 2017
    Messages:
    6,743
    You need to pay more attention to avoiding errors.

    upload_2018-7-27_13-28-23.png

    There is problem also with texture path in materials.cs and also you need to use ctrl-A to apply location, rotation and scale to bumper in Blender before exporting it.

    However it appears fine with fixes I mentioned earlier.
     
  7. ThomasPlaysOfficial

    ThomasPlaysOfficial
    Expand Collapse

    Joined:
    Apr 8, 2017
    Messages:
    144
    i did ctrl-a in blender, checked materials file,renamed my bumper to remove any possibler conflicts and did other modifications and even removed every mod i have, and it still doesnt show up as the model i selected.

    (i've attached updated file, probably even more broken)

    *EDIT*
    i did something and now the bumper just appears but invisible
    20180727133141_1.jpg
     

    Attached Files:

  8. fufsgfen

    fufsgfen
    Expand Collapse

    Joined:
    Jan 10, 2017
    Messages:
    6,743
    You have misunderstood this part a little:
    ["mesh", "[group]:", "nonFlexMaterials"],
    ["roamer_bumper_FA_TPRAM", ["roamer_bumper_FA_TPRAM"]],

    https://wiki.beamng.com/JBeam_Introduction#Flexbody

    Group there is a node group, you kinda bind your bumper mesh to.

    When you look the file, at line 52 there is definition of the group:
    "nodes": [
    ["id", "posX", "posY", "posZ"],
    //--FRONT BUMPER--
    {"nodeMaterial":"|NM_METAL"},
    {"collision":true}
    {"nodeWeight":1.2},
    {"frictionCoef":0.5},
    {"group":"roamer_bumper_F"},

    Then in your materials.cs you have this path diffuseMap[0] = "vehicles/roamer/armouredbumper/black.png";
     
  9. ThomasPlaysOfficial

    ThomasPlaysOfficial
    Expand Collapse

    Joined:
    Apr 8, 2017
    Messages:
    144
    thanks so much for the help :D

    finally, it works and i can get on with the other custom parts for my config. when my mod update comes out, i will definitely credit you for the help.
    20180727135126_1.jpg
     
    • Like Like x 2
  10. torsion

    torsion
    Expand Collapse

    Joined:
    May 31, 2015
    Messages:
    1,585
    Just a side note, I'm confident that the print messages are not a normal part of the game. When you're developing a mod it's helpful to disable or remove most/all of your other mods.

    FWIW the print messages in your screenshot came before the line saying "BeamNGVehicle::spawnObject" so you know that it's not part of the Roamer spawning process. I'd disable everything else anyway, development is much better w/ only the official problems to worry about.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice