Solved Fiat One Mod has no part tree.

Discussion in 'Mod Support' started by Andrew_5459, Jul 28, 2021.

  1. Andrew_5459

    Andrew_5459
    Expand Collapse

    Joined:
    Nov 6, 2020
    Messages:
    5
    I have been trying my best to fix a missing part tree issue with the mod mentioned but I cant seem to find any issues with the .pc files of each of the configs.

    If anyone could help me solve this issue that would be greatly appreciated. :)
     
  2. Agent_Y

    Agent_Y
    Expand Collapse

    Joined:
    Jul 10, 2020
    Messages:
    7,133
    Reinstall the mod maybe? It works for me
     
  3. Andrew_5459

    Andrew_5459
    Expand Collapse

    Joined:
    Nov 6, 2020
    Messages:
    5
    Would you be able to send me your mod file? I tried redownloading it and the same issue comes up.
     
  4. Agent_Y

    Agent_Y
    Expand Collapse

    Joined:
    Jul 10, 2020
    Messages:
    7,133
    I didn't modify my file, you probably have a conflict with another mod
     
  5. Andrew_5459

    Andrew_5459
    Expand Collapse

    Joined:
    Nov 6, 2020
    Messages:
    5
    I ran the game in safe mode with only the fait one mod active and the same problem still showed up.
     
  6. Agent_Y

    Agent_Y
    Expand Collapse

    Joined:
    Jul 10, 2020
    Messages:
    7,133
    Ok that's weird, then maybe I do have a modified version somehow, I'll check
    --- Post updated ---
    Something in the mod is very broken and I have no idea what, but after deleting the files for suspension and engine the parts menu works, but obviously you can't drive. I can't find what exactly is going on with that. But somehow it works fine for me when I have all my other mods active, some mod must be fixing it somehow but I have no idea which one.
     
  7. Andrew_5459

    Andrew_5459
    Expand Collapse

    Joined:
    Nov 6, 2020
    Messages:
    5
    I tried deleting the engine & suspension files and the part tree still didn't show up. Did you delete just the jbeam files? or everything relating to the engine and suspension?
     
  8. Agent_Y

    Agent_Y
    Expand Collapse

    Joined:
    Jul 10, 2020
    Messages:
    7,133
    I also deleted sub-slots like wheels, tires, transmission, etc.
     
  9. Andrew_5459

    Andrew_5459
    Expand Collapse

    Joined:
    Nov 6, 2020
    Messages:
    5
    Success!

    I was able to get the mod to work properly. Most of the issues I found were syntax errors like missing/extra commas in the uno.jbeam file.

    I'll upload the fixed version here but I will definitely be spending some time to further improve this mod.
     

    Attached Files:

    • Like Like x 1
  10. Franz027

    Franz027
    Expand Collapse

    Joined:
    May 8, 2020
    Messages:
    3,410
    It wouldn't be bad seeing this mod revived/updated/fixed and with new parts and configs!
     
    • Agree Agree x 1
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice