Unsolved Help, Beamng update broke the old Covets sbeam sound

Discussion in 'Mod Support' started by Inn0centJok3r, Nov 9, 2018.

  1. Inn0centJok3r

    Inn0centJok3r
    Expand Collapse

    Joined:
    Jul 16, 2018
    Messages:
    334
    So a while ago, ive posted a mod that siply adds the very old and noisy Covet sound to the Covet.
    Unfortunately the car makes no sound after the 0.14 update. Did something happen to the sbeam file?

    Here the file. Maybe it woks for you? idk
     

    Attached Files:

  2. emmabean84

    emmabean84
    Expand Collapse

    Joined:
    Jul 15, 2018
    Messages:
    32
    I think they deleted the sound. I hope I'm wrong, too.
     
  3. Alex_Farmer557

    Alex_Farmer557
    Expand Collapse

    Joined:
    Dec 28, 2016
    Messages:
    2,591
    Something about the old sbeam system was changed. Cars that use the old pre-fmod v8 sound also have no sound
     
  4. JBeam174

    JBeam174
    Expand Collapse

    Joined:
    Aug 20, 2017
    Messages:
    52
    I think that the sounds have to be wave (.wav) files instead because it's what is used in Automation to BeamNG exports. You could try converting the .sbeam files to .wav files.
     
  5. Alex_Farmer557

    Alex_Farmer557
    Expand Collapse

    Joined:
    Dec 28, 2016
    Messages:
    2,591
    Don't bump threads
     
  6. Inn0centJok3r

    Inn0centJok3r
    Expand Collapse

    Joined:
    Jul 16, 2018
    Messages:
    334
    It’s fine. I’m happy if I can find an answer to fixing the sound.
    Well the .wav files are just a newer way of doing it. The sBeam files should still work, as the Electric sbeam sound for my Rimac still works perfectly fine.
    I’ll see what other people say
     
  7. fufsgfen

    fufsgfen
    Expand Collapse

    Joined:
    Jan 10, 2017
    Messages:
    7,075
    As you can see from your soundconfig file, sample is set to be "vehicles/common/sounds/16_exhaust_710rpm.ogg" etc.

    If you go to game folder, steamapps\common\BeamNG.drive\content\vehicles\common.zip\vehicles\common\sounds you can see there is no longer samples present in that folder.

    There used to be these files:
    upload_2019-12-5_21-44-50.png

    I don't know why those sounds were removed from common.zip and other sounds were left there, but without those samples it is not possible for your sound definition to work and I don't know if it is allowed to share those samples, maybe @Nadeox1 could say yes or no for sharing those sounds.

    If they allow sharing of those samples, I could post them here and then you would just need to add sample files to your .zip and change path of your sound definition file to point to new location.
     
    • Informative Informative x 1
  8. Inn0centJok3r

    Inn0centJok3r
    Expand Collapse

    Joined:
    Jul 16, 2018
    Messages:
    334
    Oh great! Thanks!
    I don’t think using the sounds will be an issue though
    But better ask, yeah
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice