1. Issues with the game?
    Check the Known Issues list before reporting!

    Dismiss Notice
  2. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    0.25 Bug Reporting thread
    Solutions and more information may already be available.

Huge performance issue related with audio engine

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by ChatCureuil, Dec 23, 2021.

  1. ChatCureuil

    ChatCureuil
    Expand Collapse

    Joined:
    Dec 10, 2021
    Messages:
    18
    Hi,

    From 90 FPS to 40 FPS in one hour (Safe Mode, cache cleared). Audio engine is taking more and more time to render.
    This is a recent issue, I was able to play hours a few weeks ago.



    Another user on Discord (Daniel W) reported this screenshot that is probably linked with this issue.

    Clipboard02.jpg
     
    #1 ChatCureuil, Dec 23, 2021
    Last edited: Dec 23, 2021
  2. ChatCureuil

    ChatCureuil
    Expand Collapse

    Joined:
    Dec 10, 2021
    Messages:
    18
    I forgot to add this, when I closed the game I saw this error message:

    after_exiting_game.jpg
     
  3. synsol

    synsol
    Expand Collapse
    QA Lead
    BeamNG Team

    Joined:
    Aug 4, 2013
    Messages:
    1,451
    thanks , we are investigating :)
     
    • Like Like x 4
  4. PowerstrokeHD

    PowerstrokeHD
    Expand Collapse

    Joined:
    Feb 5, 2021
    Messages:
    1,478
    Just wanted to also let you know that the screenshot leads to a dead link
     
  5. ChatCureuil

    ChatCureuil
    Expand Collapse

    Joined:
    Dec 10, 2021
    Messages:
    18
    Thanks, it was a discord attachement, I added the image directly.

    Great, thanks! :D
     
  6. ChatCureuil

    ChatCureuil
    Expand Collapse

    Joined:
    Dec 10, 2021
    Messages:
    18
    Hi, can we have an ETA on this issue please?
    Actually game is broken, I can't play it more than a few minutes before FPS become ugly on my actual computer, I hope you'll fix this soon.
    Thanks.
     
    • Agree Agree x 1
  7. NoDakSmack

    NoDakSmack
    Expand Collapse

    Joined:
    Dec 24, 2018
    Messages:
    162
    I've found turning voices up to max helped my game run longer. Only got about 6 minutes until performance dumped with setting on low, can get 30+ minutes with it all the way up. Lots of derby fans are having this issue when we have a lot of cars in game.
     
    • Like Like x 2
  8. GILDO125

    GILDO125
    Expand Collapse

    Joined:
    Aug 4, 2013
    Messages:
    61
    I’ve had the same problem ish. Spawned 12 cars for a banger race. 20 mins playing and the audio goes choppy and fps goes unbearable
     
    • Like Like x 1
  9. GILDO125

    GILDO125
    Expand Collapse

    Joined:
    Aug 4, 2013
    Messages:
    61
    Anymore news on a fix? Game is pretty un playable in the state it is with 20 mins of game time before it self destructs
     
  10. Bauer33333

    Bauer33333
    Expand Collapse

    Joined:
    Jul 25, 2020
    Messages:
    96
    Yes, TDK posted that on the beamng Discord yesterday:
    Screenshot_20220121-225945_Discord.jpg
     
    #10 Bauer33333, Jan 21, 2022
    Last edited: Jan 21, 2022
    • Like Like x 2
  11. ChatCureuil

    ChatCureuil
    Expand Collapse

    Joined:
    Dec 10, 2021
    Messages:
    18
    I don't agree with words "hotfix" or "ASAP" when we're talking about a game broken since one full month...

    A "hotfix" published "ASAP" would have been to revert the broken update after discovering the issue.
     
  12. NoDakSmack

    NoDakSmack
    Expand Collapse

    Joined:
    Dec 24, 2018
    Messages:
    162
    That's an unrealistic expectation for so many reasons, but also, a fix is coming, so I wouldn't whine so much. The dev team took a break over the holidays & it's entirely unreasonable to expect them to rollback an entire half years worth of work over holiday season because a relatively small number of players are having as extreme of an issue as yourself. You also have absolutely no idea what went into getting this bug fixed or what their initial timetable for a hotfix release was. You got good news, I'd suggest taking it.
     
    • Agree Agree x 4
  13. Agent_Y

    Agent_Y
    Expand Collapse

    Joined:
    Jul 10, 2020
    Messages:
    6,813
    You should be thankful they even bothered fixing it since it definitely involved so much work that they could as well have postponed the fix until the next major update...
     
    • Agree Agree x 2
  14. ChatCureuil

    ChatCureuil
    Expand Collapse

    Joined:
    Dec 10, 2021
    Messages:
    18
    I'm a developer too and in my dev's life I too have released several updates braking a game or application used by thousands people.
    I always fixed it in a maximum of a few hours, when it was not possible to publish a hotfix in a decent delay I just rolled back the update to have more time working on it, cause I think it's unacceptable to let users with a broken application.

    That's my opinion and I had to express it. :)
     
  15. Dummiesman

    Dummiesman
    Expand Collapse

    Joined:
    Sep 17, 2013
    Messages:
    4,632
    For such a rare issue rolling back would be an over reaction.
    I've experienced this twice since the update, and only in more extreme situations with double digit cars spawned. I've launched and played the game probably somewhere between 30-50 times.

    I would hate to lose half a years of progress over this, and not only that, lose it for nearly a month over such a small issue.
    I could only imagine the backlash and negative reviews that would come from that as well.
     
    • Agree Agree x 3
  16. ChatCureuil

    ChatCureuil
    Expand Collapse

    Joined:
    Dec 10, 2021
    Messages:
    18
    That's not a rare or small issue, it's every time I launch the game, going slower each minute until FPS become unplayable (the delay before being unplayable just depends on your computer specs), then requesting a game restart, that's what we usually call a "critical" issue.
    But I won't argue more on this, that's useless, I said what I had to say, I'm not asking you to agree with my point of view. ;)
     
    • Agree Agree x 2
  17. Turbo49>

    Turbo49>
    Expand Collapse

    Joined:
    Apr 1, 2021
    Messages:
    2,514
    It doesn't happen to me though. And all i have is an averagely powerful CPU, my GPU is under average. I've played for 20-30mn without noticing any loss in fps. Are you sure it isn't simply that it happens on some devices, and not on others ?
     
  18. Agent_Y

    Agent_Y
    Expand Collapse

    Joined:
    Jul 10, 2020
    Messages:
    6,813
    If it was such a game-breaking issue, everyone would be talking about it, meanwhile I've only heard like 10 people or maybe less saying that they have it. It definitely depends on your device and 99% of the players don't have this issue.
     
  19. GianniPower

    GianniPower
    Expand Collapse

    Joined:
    Sep 8, 2017
    Messages:
    33
    I had this issue today, and I immediately recognized it was the same problem i saw in a forum post and i was searching it again but I didn’t find it. I found this thread that from what i got looks like it’s talking about the same issue, this is what i was doing: i was running cars while i was recording their path for a race and then after at least i think more than 10 minutes the game started stuttering heavily; i had msi afterburner up in the corner and it was showing 0% of usage of my gpu, everything else looked fine. Again I’m saying I immediately recognized that it was the same identical issue i saw somewhere in a bug reporting forum. I had almost 400 mods (i tested all of them one by one and discarded thise who weren’t working) i was running on a modded map with modded cars but when i changed map the lag spikes kept going on. I should try with further tests, maybe changing audio settings, using Vulkan mode, testing without mods, clearing cache, reinstall gpu drivers (my pc specs are above average so that’s not a problem). Hope this get a fix soon. I apologize if I bothered someone with this. It may be happening to the 1% of users but when it happens it’s really game breaking and unplayable.
    Edit: I did again everything the same to make it happen forcefully and it happened again after the same amount of time, i opened the console and the error is the same as in the original post picture.
     

    Attached Files:

    • Screenshot150.png
    #19 GianniPower, Jan 22, 2022
    Last edited: Jan 23, 2022
  20. NoDakSmack

    NoDakSmack
    Expand Collapse

    Joined:
    Dec 24, 2018
    Messages:
    162
    It seems universal among players that run derbies with multiple cars, but for it to happen with a single vehicle I've only heard of a few people having that issue. The duration of playtime before lagging also varies a bit.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice