1. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    0.22 Bug Reporting thread
    Solutions and more information may already be available.

Setting up keybinds bug

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by Lethal_Drifter1, Mar 31, 2021.

  1. Lethal_Drifter1

    Lethal_Drifter1
    Expand Collapse

    Joined:
    Oct 21, 2019
    Messages:
    6
    The keybinds that you set or delete don't update when you click "apply".

    The only fix for this is when you go to the menu and you return back to the keybind menu.
     
  2. NOCARGO

    NOCARGO
    Expand Collapse

    Joined:
    Apr 1, 2019
    Messages:
    1,292
    Yes it seems to work but the result is not visible until you leave the menu and reopen it again, I reported that in 0.22 discussion thread :
    https://www.beamng.com/threads/0-22...e-before-reporting.77942/page-23#post-1301812
     
  3. stenyak

    stenyak
    Expand Collapse
    BeamNG Team

    Joined:
    Aug 6, 2012
    Messages:
    1,342
    Thanks for reporting. This issue will be fixed in the next update :)
     
  4. Agent_Y

    Agent_Y
    Expand Collapse

    Joined:
    Jul 10, 2020
    Messages:
    2,271
    Can you also fix the bug with no mod key bindings working properly? Some override vanilla bindings (and they used to add to them before) and others just straight up do nothing (and they used to work before 0.22)
     
  5. stenyak

    stenyak
    Expand Collapse
    BeamNG Team

    Joined:
    Aug 6, 2012
    Messages:
    1,342
    I have fixed other issues related to mod bindings but it may or may not be the same issue that you're mentioning.
    Can you clarify with as much detail as possible what you mean? Please provide an example and instructions so I can attempt to reproduce on my side.
     
  6. Agent_Y

    Agent_Y
    Expand Collapse

    Joined:
    Jul 10, 2020
    Messages:
    2,271
    Dumb forums deleted my long message where I described in detail what happened and instantly saved the draft so I can't load. Basically the bindings override happens for the pickup with the file input_actions_cbpmod.json being in the pickup folder and the keyboard file being in pickup/inputmaps. Before 0.22 the bindings would add to the pickup ones and now they delete the current ones. The other issue with key bindings not working (they work for me, but not for the people using my mod, they have to set them manually) is with the Wendover, the input_actions_jumpsystem.json file is in the wendover folder and keyboard2.json (normally called keyboard.json in the mod) is in wendover/inputmaps. Check if these bindings don't delete the vanilla ones for you, all files attached, they don't do anything by themselves, all lua is in other files.
     

    Attached Files:

  7. stenyak

    stenyak
    Expand Collapse
    BeamNG Team

    Joined:
    Aug 6, 2012
    Messages:
    1,342
    Which mod is that? I'd like to test under the original conditions if possible, rather than trying to replicate the ennvironment on my own (which I may do incorrectly).
     
  8. Agent_Y

    Agent_Y
    Expand Collapse

    Joined:
    Jul 10, 2020
    Messages:
    2,271
    That's not released yet, but the same thing basically happens on every mod that adds new key bindings to a vehicle that already has them by default, I tried to find examples but all the mods I knew of that did it either are gone from repo or work by overwriting files ON PURPOSE, people have no idea how to make mods... But here's a link to my mod that has the Wendover issue: https://www.beamng.com/resources/ve...e-and-other-values-edit-works-for-mods.14868/ I have no idea why this works for me but not for other people.
     
  9. lord_of_the_wolves

    lord_of_the_wolves
    Expand Collapse

    Joined:
    Mar 6, 2016
    Messages:
    6
    Ive also have the bug with my g920, except i cant modify my FFB settings, and will enable/disable certain features after every apply is made. So far its disabled FFB and i cant turn it back on, and resetting to defaults doesn't do anything either.

    Sometimes you can adjust the steering ratio and lock, but if you do anything more it just resets. some one else on Reddit was having the same issue with their thrustmaster wheel too
     
  10. stenyak

    stenyak
    Expand Collapse
    BeamNG Team

    Joined:
    Aug 6, 2012
    Messages:
    1,342
    This issue affects 100% of users who try to configure controls. But as mentioned, the issue has already been fixed, and the bugfix will arrive in the next update :)


    I have installed that mod. The 'T' key works for me in the FATT69000 config. The default wendover has no additional bindings to override, so only the T binding shows up, which is normal. Could you please provide me step-by-step instructions to reproduce the issue? I'm afraid I still don't understand what exactly I should be looking for in the wendover mod.
     
  11. Agent_Y

    Agent_Y
    Expand Collapse

    Joined:
    Jul 10, 2020
    Messages:
    2,271
    I don't know the exact steps other people did that made it not work for them. It works for me but not for them somehow. As for the other issue with overriding, this version of my other mod overrides walking mode controls, in attached file. Before 0.22 something like this would just add new bindings. It makes it impossible to walk with this mod active so I had to remove the inputmaps folder in the version for repo.
     

    Attached Files:

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice