Trouble with my custom H-series skin

Discussion in 'Content Creation' started by comradeblackwolf, Jun 28, 2022.

  1. comradeblackwolf

    comradeblackwolf
    Expand Collapse

    Joined:
    Jul 4, 2021
    Messages:
    4
    Hi everyone. Long time player/forum lurker here. I've never needed to make a post as the answer is usually found before I resort to needing to make a post.

    I have been working on a simple skin for the H-Series and while it does show up in the parts selector, it shows up with some unwanted textures/errors (see image)

    I've looked at as many posts here and videos and even reddit possible to see if there is a reason this may be happening. I've recreated my skin twice to hope there was something I did wrong that I could catch myself but I cannot see what I've done wrong. I've cleared my cache and did a deep clean as well. I also have zero issues with any other skin or any other part of the game so im sure its something I've done. I've also attached the folder for the skin I made to help as well. Thank you!



    *Update*

    I was informed on reddit that the materials.cs is outdated. however other van skins still use materials.cs just fine. I tried using the newer matrerials.json with no luck. That resulted in no weird textures but an orange no texture paint. I've gone as far as testing an existing skin that works and replacing it with my .dds with a name change to match that mod and that doesn't work either. I've been fiddling with this for a few days now and I'm likely going to take a break. It's driving me nuts.
     

    Attached Files:

    #1 comradeblackwolf, Jun 28, 2022
    Last edited: Jun 28, 2022
  2. PowerstrokeHD

    PowerstrokeHD
    Expand Collapse

    Joined:
    Feb 5, 2021
    Messages:
    1,662
    Have you tried disabling any mods that may be installed?
     
  3. comradeblackwolf

    comradeblackwolf
    Expand Collapse

    Joined:
    Jul 4, 2021
    Messages:
    4
    Yeah, I ran the game with nothing but the skin enabled and that did not fix anything either. other than this specific skin, I have no texture problems at all. everything else runs perfectly so I'm sure it was something I did wrong in creating the skin. The .DDS file seems totally fine and doesnt have those textures present when opened, its literally just a white background and the vengeance graphic so im doubtful its from the dds file either.
     
  4. sg2222

    sg2222
    Expand Collapse

    Joined:
    Jun 23, 2022
    Messages:
    1
    i'm guessing it's because you're still using the old materials.cs format for your skin. the game uses a .json format file now. i looked through the file, and many things in there are still pointing towards the old van textures pre-remaster (ex. van_d.dds is an old texture, van_main_b.color.dds is its new version)

    there's an updated tutorial for skins in the beam documentation, should point you in the right direction: https://documentation.beamng.com/modding/materials/vehicle/skinsystem/skintutorial/

    edit: saw your update on attempting to get this to work. mb that this post showed up after the fact, had to get it approved by a mod just to show up. guessing its because my account is so new. regardless i hope the above tutorial can help
     
    #4 sg2222, Jun 28, 2022
    Last edited: Jun 28, 2022
  5. Agent_Y

    Agent_Y
    Expand Collapse

    Joined:
    Jul 10, 2020
    Messages:
    7,137
    STOP USING EXTREMELY OUTDATED MATERIALS PEOPLE
    You can't just take the materials file from some 2013 mod and expect it to work in 2022... Why don't you use materials from vanilla vehicles??? Literally everyone who has skin problems uses some outdated materials, do you all follow some extremely outdated tutorial or what?
     
  6. comradeblackwolf

    comradeblackwolf
    Expand Collapse

    Joined:
    Jul 4, 2021
    Messages:
    4
    its not from some 2013 mod, I made the material files myself from multiple different tutorials all confirmed working as of June this year. Apparently this method does not in my case. There aren't any newer updated tutorials as there hasnt been one since Jan of this year according to my searches. To answer your second question I did. That still not not work for me.
     
  7. Agent_Y

    Agent_Y
    Expand Collapse

    Joined:
    Jul 10, 2020
    Messages:
    7,137
    What kind of tutorial confirmed to work June this year still uses cs materials, they have been outdated for years. And if using vanilla materials didn't work then no idea what you are doing wrong.
     
  8. Bexcon

    Bexcon
    Expand Collapse

    Joined:
    Apr 27, 2017
    Messages:
    30
    You need to change the skin resolution from 2048 px to 4096 px, and yes you better use materials.json

    EDIT: Here's the version with all the fixes
     

    Attached Files:

    #8 Bexcon, Jun 28, 2022
    Last edited: Jun 28, 2022
    • Like Like x 1
  9. comradeblackwolf

    comradeblackwolf
    Expand Collapse

    Joined:
    Jul 4, 2021
    Messages:
    4
    I'm unsure myself. I'm gong to read up more on the info down below. I wanna get better at doing this. Thanks for reaching out.
    --- Post updated ---
    That makes a lot of sense. All the tutorials on youtube were using the old materials format which is definitely my problem. Thank you for the link ill check it out and get more familiar with the .json format. I appreciate your help!
    --- Post updated ---
    Thank you so much, you didnt have to do that! I appreciate it! I'll mark the thread as solved.
     
    • Like Like x 1
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice