0.10.0.1 Discussion/Feedback/Bugs-Reporting Thread - READ #1 POST!

Discussion in 'General Discussion' started by Nadeox1, Aug 7, 2017.

Thread Status:
Not open for further replies.
  1. Nadeox1

    Nadeox1
    Expand Collapse
    BeamNG.Support
    Staff Member

    Joined:
    Aug 5, 2012
    Messages:
    13,862
    Check mods.
    Check settings.
    If problem persists, clean reinstall (instruction in first post)
     
  2. DasCreeper

    DasCreeper
    Expand Collapse

    Joined:
    Jan 4, 2015
    Messages:
    24
    it wont even load in the menu i have 1 fps and in game i have 9
     
  3. KJP12

    KJP12
    Expand Collapse

    Joined:
    Jul 26, 2016
    Messages:
    717
    Me before this update: "Hype! I want an update!"

    Me after this update:




    The Sounds


    The original V8 sound (which is now just a place holder) is broken. It sounds like either nothing or full blast. The new engine sounds are too quiet, and sounds more like a rotary engine. The crash sounds.... What sounds? Glass breaking? Let me toss it through one of my large spinners... Ouch! My ears! It's too loud!

    Also, the T-Series sounds like it's farting. Quite literally.

    The sounds of the tires screeching across the ground... they just don't sound right. It sounds like someone decided to butter up a piece of rubber, push it across the road with something, then made it high pitch.

    New Map, Vehicles & Props


    The new piano? It's alright. Definitely different.

    Now for the new map. It's just a showroom. Nothing much special about it.

    The new "vehicles?" We only got 2 new trailers. I have nothing to complain about there. It's something that a pigeon can finally haul, without the suspension going down soo far.

    FPS


    I heard that there's new AI. Let me just load up Utah... wtf happened to the frame rate? 30-35 FPS average? That can't be right. Let me load up Dry Rock Island... last I checked, it had around 27 average. Wait... 32-33 FPS? DRI is performing just as well as Utah. What happened? Let me go to East Coast, USA. Whaa... 25 FPS at the start?! 0.9.0.5 with DRI performed better with 27. After a bit, it averaged to 30... DRI still is better. Then wait more and it reached to 33. Is every map based off of DRI now, or is the update badly optimized? Well, lets get back to the AI.

    AI


    I decided the best way to see if the AI have improved is do an AI run on ECUSA, with the pigeon going random while the T-Series is chasing it, on similar settings as possible.

    The pigeon managed to drive into a tree. Did I misunderstood a setting?
    screenshot_00194.png

    At least the chasing AI improved. Didn't crash yet.
    screenshot_00195.png

    At the end of it


    Probably should've waited til all of the bugs are fixed. Hopefully one of the hot-fixes will improve some of the issues.
     
    #163 KJP12, Aug 9, 2017
    Last edited: Aug 10, 2017
    • Like Like x 1
    • Agree Agree x 1
  4. Nadeox1

    Nadeox1
    Expand Collapse
    BeamNG.Support
    Staff Member

    Joined:
    Aug 5, 2012
    Messages:
    13,862
  5. Goosah

    Goosah
    Expand Collapse
    Global Moderator
    Staff Member

    Joined:
    Aug 30, 2013
    Messages:
    787
    Thank you for that. I agree the shift points were too high for low throttle. It is a problem left over from when the code used to look at the engine rpm (which is higher due to torque converter slip). I've now reduced the shift points for automatics a bunch. It is nice to see that people enjoy cruising in this game, it makes it feel worthwhile to develop the automatics and all the complexity of the shift code when other games don't bother, and just expect you to go full throttle everywhere.
     
    • Like Like x 12
    • Agree Agree x 3
  6. nikobelichgta5

    nikobelichgta5
    Expand Collapse

    Joined:
    Aug 6, 2013
    Messages:
    100
    Thank you! It's so pleasure to see how developers communicate with their players! Awesome! BTW Great optimization work made.
     
  7. DD-Indeed

    DD-Indeed
    Expand Collapse

    Joined:
    Jun 22, 2016
    Messages:
    409
    Issues I witnessed by far:

    - Starter motor is still functional after waterlocking the engine.
    - AI is broken in some scenarios, Drag Race is one of them.
    - Orbit-camera is shaking a lot with wobbly cars such as Pigeon.
     
  8. MrAngry

    MrAngry
    Expand Collapse

    Joined:
    Sep 5, 2013
    Messages:
    653
    I found a bug with the replay system (this might be a feature but I'm not entirely sure).

    After recording a replay and while in "playback" mode, when I switch to another map I spawn with frozen physics. Once I unfreeze the physics the game loads the previous level and returns me to where I left off with the replay playback. I think there should be some form of a dialogue window which would ask the user if he wants to discard the current replay and switch levels.
     
  9. Curiousjay1

    Curiousjay1
    Expand Collapse

    Joined:
    Oct 15, 2015
    Messages:
    1
    So, I went into East Coast, and I immediatly saw a tree near me going back and forth at an unreal rate, and it was glitching around everywhere. Eventually the tree did calm down, but then some others started with the same thing. You need to look into this. Its almost scary.
     
  10. EcoNadder77

    EcoNadder77
    Expand Collapse

    Joined:
    May 29, 2017
    Messages:
    1,118
    Weird little bug I stumbled upon:
    When I installed the update and ran BeamNG as a clean installation, I was unable to switch to the vehicle camera. I had either free roam, or a floating view that was locked to a certain position. I restarted the game several times, and it still occurred. Finally, when I clicked verify integrity, it said no problems found, but the camera was then fixed. I don't know if anyone else has this problem, but verifying the integrity seemed to do the trick.
     
  11. ManfredE3

    ManfredE3
    Expand Collapse

    Joined:
    Jan 9, 2016
    Messages:
    2,068
    I am able to run an extra car at full FPS compared to last update. Just trying to have a post on this page that is positive. Don't kill me.
     
  12. Justy4WDTURBO

    Justy4WDTURBO
    Expand Collapse

    Joined:
    May 14, 2016
    Messages:
    464
    OH MY GOD A KNIGHT INDUSTRIES TRAILER YES YES!

    THANK YOU DEVS!
     
  13. CharredWing

    CharredWing
    Expand Collapse

    Joined:
    Feb 24, 2017
    Messages:
    560
    tis updaet is C O O L A N D G O O D
     
  14. FLyInG 2 YoUr SoUL

    FLyInG 2 YoUr SoUL
    Expand Collapse

    Joined:
    May 31, 2016
    Messages:
    5,083
    Pessima Mk1: "NO MATERIAL" on blinkers with the Widebody Front Fenders.
     

    Attached Files:

    • blinkers.jpg
    • Agree Agree x 1
  15. EcoNadder77

    EcoNadder77
    Expand Collapse

    Joined:
    May 29, 2017
    Messages:
    1,118
    Vehicles and props rotate when you move them with F7. The closer to the ground they are, the sharper their pitch. All the objects in this picture were initially sitting level on the ground. I paused BeamNG, and used F7 to move them. This was the result:
    screenshot_00004.png
     
  16. Giraffinator

    Giraffinator
    Expand Collapse

    Joined:
    Sep 5, 2016
    Messages:
    833
    The objects are rotated to where the camera is looking now, not a bug. (I don't think)
     
  17. iheartmods

    iheartmods
    Expand Collapse

    Joined:
    Aug 8, 2012
    Messages:
    1,484
    You guys have outdone yourselves. I'm so impressed with the sound rework, you have no idea *beams*
     
  18. DriftinCovet1987

    DriftinCovet1987
    Expand Collapse

    Joined:
    Apr 14, 2016
    Messages:
    904
    I especially love the demonic SBR4 sound...man, if there was a car that sounded like that, I would buy it no matter how much power it had.
     
    • Agree Agree x 4
  19. EcoNadder77

    EcoNadder77
    Expand Collapse

    Joined:
    May 29, 2017
    Messages:
    1,118
    Thanks. I missed that addition within the devblog. My bad.
     
  20. TYLERTJ

    TYLERTJ
    Expand Collapse

    Joined:
    Aug 18, 2013
    Messages:
    681
    Did I miss the piano in the DevBlog, or is it actually not in there?

    Haven't had a chance to try the update yet, but I will as soon as I get home.
     
    • Agree Agree x 1
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice