0.14 Discussion/Feedback/Bugs-Reporting Thread - READ #1 POST!

Discussion in 'General Discussion' started by Nadeox1, Oct 29, 2018.

  1. CrimsonCrocodile

    CrimsonCrocodile
    Expand Collapse

    Joined:
    Jun 27, 2017
    Messages:
    216
    Similar to this, whenever I download a mod off the repo the game always freezes twice for about a minute each time. Once at 97/98% and then again at 100%.

    My antivirus is Norton Security, so any suggestions how to fix this without disabling antivirus or is it a bug?
     
  2. Tsutarja495

    Tsutarja495
    Expand Collapse

    Joined:
    Mar 16, 2014
    Messages:
    648
    I think it has something to do with the way that mods are installed.
     
    • Informative Informative x 1
  3. Nadeox1

    Nadeox1
    Expand Collapse
    BeamNG.Support
    Staff Member

    Joined:
    Aug 5, 2012
    Messages:
    12,060
    We found and fixed something related to that.
    Will be in the next hotfix.
     
    • Like Like x 2
    • Informative Informative x 1
  4. Nadeox1

    Nadeox1
    Expand Collapse
    BeamNG.Support
    Staff Member

    Joined:
    Aug 5, 2012
    Messages:
    12,060
    • Like Like x 4
    • Staff Pick Staff Pick x 1
  5. Kencet Kencet

    Kencet Kencet
    Expand Collapse

    Joined:
    Friday
    Messages:
    1
    Can we please change the vehicle orbit cam back to normal when you have trailers connected
    ITS REALLY ANNOYING
     
    • Informative Informative x 1
  6. Nadeox1

    Nadeox1
    Expand Collapse
    BeamNG.Support
    Staff Member

    Joined:
    Aug 5, 2012
    Messages:
    12,060
    That camera mode is not done yet, we will possibly go over that again later on.
     
  7. Crash Hard 01

    Crash Hard 01
    Expand Collapse

    Joined:
    Aug 5, 2013
    Messages:
    743
    Wow!
    New max beams limit is 65534. is this pr. car/truck? And is there a new node limit as well?
     
  8. fufsgfen

    fufsgfen
    Expand Collapse

    Joined:
    Jan 10, 2017
    Messages:
    4,883
    Some track editor related curiosities.

    I did open my track builder track in Gridmap, then I did hit esc twice and I have track visible like so without track editor open, not sure if this should happen:
    upload_2018-11-9_18-2-55.png

    If I select drive in track editor, then hit ctrl-e and select new vehicle, track editor is in drive mode, but this shows up:
    upload_2018-11-9_18-4-44.png

    3rd finding....

    If I select drive in track editor, then click UI element like range box to low like here, this happens:
    upload_2018-11-9_18-6-15.png

    So bug is somewhere when UI is touched, I think.
     
    • Informative Informative x 1
  9. Alex [ITA]

    Alex [ITA]
    Expand Collapse

    Joined:
    Apr 1, 2016
    Messages:
    246
    I think the repo is breaking the gameā€¦
    I was in "Safe Mode" because I had to check a thing I experienced in the "Normal Mode"; the repo started downloading an update for a mod (a map so it's pretty large to download) and when I pressed "EXIT" in the main menu, the game froze (unfortunately it didn't crash) blocking me to get to any other app. I could press CTRL+ALT+DEL and launch the task manager, but sadly, the game refused to go in background, so I couldn't end BeamNG process.
    Is there any way I can unsubscribe from a mod before it finishes the download?
     
  10. Nadeox1

    Nadeox1
    Expand Collapse
    BeamNG.Support
    Staff Member

    Joined:
    Aug 5, 2012
    Messages:
    12,060
    Normal-ish.
    The game is preventing you to get a corrupt/incomplete file (which you'd get if you kill the game process while it's downloading something).
    The game would have resume and closed as soon the download finished.

    At the moment you cannot stop a download if it has already started. But you can turn off the Automatic Mod Updates from the settings.
     
    • Informative Informative x 2
  11. Alex [ITA]

    Alex [ITA]
    Expand Collapse

    Joined:
    Apr 1, 2016
    Messages:
    246
    All right, thank you!
     
  12. Crash Hard 01

    Crash Hard 01
    Expand Collapse

    Joined:
    Aug 5, 2013
    Messages:
    743
    Hey just a question, would it be possible to have a load/save option for the AI app? Something like I set up all the ai stuff, topspeed, chase, targetcar, and so on. then save it, and then being able to load those settings for any other car (Would make setting up 60+ AI cars a lot easier)
     
    • Agree Agree x 1
  13. fufsgfen

    fufsgfen
    Expand Collapse

    Joined:
    Jan 10, 2017
    Messages:
    4,883
    UI app to reset(R) any vehicle without tabbing to it as a bonus? :D
     
  14. The F12 of Maranello

    The F12 of Maranello
    Expand Collapse

    Joined:
    Jan 29, 2017
    Messages:
    1,248
    Is that just me, or BeamNG's latest update have somewhat became sluggish while gameplay? Previously I could run this game at 60FPS in max settings, now I couldn't even get a stable 50.
     
  15. Michaelflat

    Michaelflat
    Expand Collapse

    Joined:
    Jul 10, 2014
    Messages:
    1,403
    ugh my bus mod broke again, it worked before the 2nd hotfix, now it has yet again pulled some random torque converter behaviour out of a hat :p
     
  16. Brickfalcon

    Brickfalcon
    Expand Collapse

    Joined:
    Jul 19, 2017
    Messages:
    95
    I updated to the latest version using steam and beamng shows 14.02 but
    • Fixed being able to click on Track pieces while in Drive or Test mode
    • Fixed obstacle placement not working
    didn't change for me. It still clicks on the track during drive mode and obstacles don't remove.
    Not sure if this is a bug or just my problem.
    Running in safe mode.
     
  17. Danny Werewolf

    Danny Werewolf
    Expand Collapse

    Joined:
    Mar 31, 2017
    Messages:
    1,091
    Soooo...I tried updating my game via steam like, 5 hours ago and ever since, it never actually completed downloading the second hotfix. It's always 90%-100% done but never finishes and never opens. When I let it keep going, it just says "Connection Timeout" and goes back to 'Update Pending'. Verifying Integrity via Steam isn't doing much as it simply says 'all files are successfully validated' but it still doesn't work.

    I think I restarted and shut down my laptop maybe, 7 times already, but that never worked.

    I looked on the steam community tab for Beam (Because this sounds like a Steam problem) and maybe a few hours earlier, someone talked about I think the same problem, and Nadeox1 said there was an issue with the files or something seeming to be flagged and blocked or something.

    I thought adding an Exclusion for every folder inside C:\Program Files (x86)\Steam\steamapps\common\BeamNG.drive but it did nothing, still not doing anything. I also scanned that folder and Windows Defender didn't find any viruses (Wouldn't be very surprised if that's just Windows Defender being stupid)

    2018-11-09.png
    This is how the download always looks.
     
  18. PriusRepellent

    PriusRepellent
    Expand Collapse

    Joined:
    Mar 19, 2018
    Messages:
    111
    This isn't Windows Defender being dumb, it is Steam. Clear your Steam download cache and try again. Steam > Settings > Downloads > Clear download cache
     
  19. fufsgfen

    fufsgfen
    Expand Collapse

    Joined:
    Jan 10, 2017
    Messages:
    4,883
    Try exclusion to Documents\BeamNG.Drive too, maybe temporary disable defender.

    Also make sure there is enough disk space, it might take quite bit more than downloaded amount, but you probably have more available anyways.

    Last resort is to uninstall BeamNG and then remove folders and reinstall. Just move user folder to safe place before doing that.

    That is all I managed to figure out for now.

    Try first what PriusRepellent suggested, that probably works and saves the hazzle.
     
  20. RBGamer100

    RBGamer100
    Expand Collapse

    Joined:
    Sep 1, 2014
    Messages:
    4
    The Force Induction Debug app is broken for me as of 0.14.0.1(i don't know about 0.14.0.0) and is still broken in 0.14.0.2, I have tried clearing the games cache and verifying the games integrity, safe mode and multiple restarts of my PC. Also what happened to the Creator Console? seems to no longer be enabled and now there is no option to even enable it?
     

    Attached Files:

    • BeamNGDrive_Broken_Force_Induction_Debug01401and01402.png
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice