Automation Exporter Feedback & Bug Reporting Thread

Discussion in 'General Discussion' started by Nadeox1, Jul 13, 2018.

  1. Skropeling

    Skropeling
    Expand Collapse

    Joined:
    Jan 21, 2018
    Messages:
    23
    The lights on Automation cars don't really do anything at night.
     
  2. Nadeox1

    Nadeox1
    Expand Collapse
    BeamNG.Support
    Staff Member

    Joined:
    Aug 5, 2012
    Messages:
    13,810
    On the most recent exports they do work fine here.
    May be your vehicle hitting some corner-case.
    Or you just have your lighting graphical setting on 'lowest', which means no dynamic lighting.
     
  3. Skropeling

    Skropeling
    Expand Collapse

    Joined:
    Jan 21, 2018
    Messages:
    23
    I'll give it a quick redo and see if I get different results, I have have my lighting on high so it's probably something to do with the export.
     
  4. bngdoodaus

    bngdoodaus
    Expand Collapse

    Joined:
    May 2, 2017
    Messages:
    29
    no plans to do basic interiors or better crash damage physics and parts?
     
    • Agree Agree x 1
  5. Nico1968

    Nico1968
    Expand Collapse

    Joined:
    May 9, 2019
    Messages:
    2
    when I import my car the wheels are bouncing around and Explode. If i do it on grass some times it will work for me but 15% chance at max what can i do to fix it ?
     

    Attached Files:

  6. Nico1968

    Nico1968
    Expand Collapse

    Joined:
    May 9, 2019
    Messages:
    2
    managed to fix the bug in that I Exported the care several times till it worked think it was export 7 that finely worked.
     
  7. SinjnCortes

    SinjnCortes
    Expand Collapse

    Joined:
    Aug 14, 2017
    Messages:
    8
    I've exported a couple vehicles from Automation to Beam and I had problems with both. The first one had the smallest stroke/widest bore that revved to 12k RPM. But once you spawned it in, the engine would be starved of oil and would shut off before you reached the top of the rev range. The second is a car with a max sized boxer 4 making 1200hp. The power comes in fairly linearly but in 3rd gear, doesn't rev to redline. In 4th, the revs will rise to a lower point. I have the gearing set to meet the estimated top speed without changing the spacing but it shouldn't have problems with as low a gear as 3rd. I've tried disabling all mods and the problem still persists.
     
  8. Inn0centJok3r

    Inn0centJok3r
    Expand Collapse

    Joined:
    Jul 16, 2018
    Messages:
    334
    The problem with the first car is too much beamspring in the engine jbeam. The engine vibrates and causes weirdums. That’s something caused by the exporter. You can fix it by going into the main jbeam and then finding the engine beams. You then have to lower the beamspring values yourself. I recommend Notepad++ for that (it’s free)
    The second car is basically flawless, the only issue is that automation exports a top speed limiter for cars. It seems as if you hit automation‘s predicted top speed of the car. You can remove the limiter in the engine jbeam. The value is called „topSpeedLimit“. Just remove it
     
  9. SinjnCortes

    SinjnCortes
    Expand Collapse

    Joined:
    Aug 14, 2017
    Messages:
    8
    Hello, thank you for the help although I'm a little confused. I've found the engine beamsprings but I'm not sure what portion to change. In the engine section near the top of the list, there is this line:
    {"beamSpring":36115232,"beamDamp":902},

    Then a lit bit further down, there is these lines of code:
    {"beamStrength":347014},
    {"beamDeform":13880}
    {"beamSpring":2777506,"beamDamp":69},
    ["engine0", "a21"],
    {"beamStrength":231343},
    {"beamDeform":9253}
    {"beamSpring":1851671,"beamDamp":46},

    The continue a good ways down and I'm curious if I'm supposed to change all of these beamSpring values or just the top one. What also is a good value to change it to?
     
  10. Inn0centJok3r

    Inn0centJok3r
    Expand Collapse

    Joined:
    Jul 16, 2018
    Messages:
    334
    I would just change the value of 36 million
    Thats waaaay too high and should fix the issue
     
  11. SinjnCortes

    SinjnCortes
    Expand Collapse

    Joined:
    Aug 14, 2017
    Messages:
    8
    Excellent. Thank you for the help. The first car now works great. However, I'm having difficulty with the second car now. I extracted the files from the zip file, opened the engine jbeam file in notepad++, found the top speed limiter and deleted it. I saved the file and zipped the folder. Now there is the old broken zip file and another new (supposedly) fixed zip file in the mod folder however, the file appears in the repository but doesn't allow me to select from the car list. This method worked for the previous car so I'm not sure what my issue is.
     
    #231 SinjnCortes, Oct 16, 2019
    Last edited: Oct 16, 2019
  12. Inn0centJok3r

    Inn0centJok3r
    Expand Collapse

    Joined:
    Jul 16, 2018
    Messages:
    334
    Is the zip in the mods folder or the unpacked folder?
     
  13. SinjnCortes

    SinjnCortes
    Expand Collapse

    Joined:
    Aug 14, 2017
    Messages:
    8
    There is 1 unzipped folder and 2 zipped folders (one modified and the original)
     
  14. Inn0centJok3r

    Inn0centJok3r
    Expand Collapse

    Joined:
    Jul 16, 2018
    Messages:
    334
    Yeah but in which folder are they
     
  15. SinjnCortes

    SinjnCortes
    Expand Collapse

    Joined:
    Aug 14, 2017
    Messages:
    8
    C:\Users\sinjn\Documents\BeamNG.drive\mods
     
  16. Inn0centJok3r

    Inn0centJok3r
    Expand Collapse

    Joined:
    Jul 16, 2018
    Messages:
    334
    If the unzipped one is in the normal mods folder, then the mod won’t be seen by beam. You have to place the mod in a folder named „unpacked“ , which has to be in the mods folder (create it yourself if it isn’t there)
     
  17. SinjnCortes

    SinjnCortes
    Expand Collapse

    Joined:
    Aug 14, 2017
    Messages:
    8
    You are fantastic! Both cars are working great (tuning sucks but working as they should nonetheless).
     
    • Like Like x 1
  18. Fast1029384756J

    Fast1029384756J
    Expand Collapse

    Joined:
    Jul 14, 2019
    Messages:
    69
    Hi, so i made a car using the 00s moped modded body and when i was exporting the car to beam it gave me a warning that said negative bottom weight and some number (can't remember the number) i pressed ok hoping that nothing bad happened and you can guess what happened, something bad happened basically the rear wheels fall off when it spawns in, rest of the car works fine. the car weighs around 460-469kg and i'm 100% this is the issue, is there a particular minimum weight to automation cars that make them export right or is this not the issue. so before i posted this i tried for 3 hours to get it to work using the mod creators advice he gave to other people but to my severe disappointment nothing worked in fact it got worse, since i can't upload the .car file i'm gonna put it in a .zip that you should be able to put in the import folder with the mod and try to help as i have run out of ideas completely on how i can fix it if thats even possible since i remember the etk w series having a similar issue after that one update that added the bluebuck, traffic, etc so perhaps a beam update broke the mod but i would love to have this working so thanks in advance
     

    Attached Files:

  19. Inn0centJok3r

    Inn0centJok3r
    Expand Collapse

    Joined:
    Jul 16, 2018
    Messages:
    334
    Your rear suspension very likely is under servere stress. You should try to lower the beamspring of the rear suspension (only the main suspension slot, dont change any values in the coilovers etc)
    Low-weight automation cars tend to break quite often, you sometimes just have to jbeam edit them.
     
  20. Fast1029384756J

    Fast1029384756J
    Expand Collapse

    Joined:
    Jul 14, 2019
    Messages:
    69
    k, thanks i'll try that in a bit and hopefully that works
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice