1. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    Solutions and more information may already be available.
  2. GPU Fatal Error? Intel HD Graphics 620/630 Crashes? Help us solve them!
    Dismiss Notice

Clutch disengaging at random / Input

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by -LeveQ-, Nov 3, 2019.

  1. -LeveQ-

    -LeveQ-
    Expand Collapse

    Joined:
    May 31, 2015
    Messages:
    10
    Hey,

    So I'm having a problem where my clutch will give about 3/4 input at random times, and you have to stab it again to put it to 0%. Sometimes it'll even get stuck no matter what needing a game restart.

    Wheel is a Thrustmaster T-GT. The clutch input looks fine in the profiler, and I've no issues in other games.

    Also, it doesnt happen on every cars, and some more than others. I would say its a weird way for the game to simulate clutch slip on weak transmissions, but since it sometimes get stuck period I dont think so.

    So yeah, halp.
     
  2. Nadeox1

    Nadeox1
    Expand Collapse
    BeamNG.Support
    Staff Member

    Joined:
    Aug 5, 2012
    Messages:
    13,522
    What Gearbox settings and assistants are you using? (Options > Gameplay)
    Test your pedal in the Controls > Hardware menu, and see if it's reporting correctly.
    Does the pedal appear stuck also in the 'Pedals' app when it happens? (https://wiki.beamng.com/User_Interface_&_Apps)
     
  3. -LeveQ-

    -LeveQ-
    Expand Collapse

    Joined:
    May 31, 2015
    Messages:
    10
    Realistic, all manual.

    When it does happen, it also shows it in the hardware menu and the pedal app (It's around 66% stuck on, only the clutch). However outside the game it's perfectly fine.
     
  4. Nadeox1

    Nadeox1
    Expand Collapse
    BeamNG.Support
    Staff Member

    Joined:
    Aug 5, 2012
    Messages:
    13,522
  5. Ai'Torror

    Ai'Torror
    Expand Collapse

    Joined:
    Aug 29, 2015
    Messages:
    1,770
    If that won't work, try cleaning the potentiometers on your clutch pedal if you've got at least some experience working with electronics
     
  6. -LeveQ-

    -LeveQ-
    Expand Collapse

    Joined:
    May 31, 2015
    Messages:
    10
    Again, profiler shows the pedal is completely fine, and it doesn't do that in other games. And Steam settings seem ok. Crappy cellphone pics incoming :)
     

    Attached Files:

    • 75339699_430483680975684_3722174505896902656_n.jpg
    • 74794296_727904187686152_5102113829853069312_n.jpg
    • 71580983_2461013070844334_3686091953067261952_n.jpg
  7. Nadeox1

    Nadeox1
    Expand Collapse
    BeamNG.Support
    Staff Member

    Joined:
    Aug 5, 2012
    Messages:
    13,522
    Are you playing with the profiler open?
    By our experience, that can cause other kind of issues. Please always close it before playing.

    What do you mean by 'Steam settings seems ok'. What are those set to?
     
  8. -LeveQ-

    -LeveQ-
    Expand Collapse

    Joined:
    May 31, 2015
    Messages:
    10
    No, only opened it to make sure the pedal itself was fine.

    As for Steam settings, as you hinted before, all support stuff is unchecked. Other than that I dont really know. Again, only happens in this game.

    It's a really weird problem, doesnt happen all the time, and sometimes it only happens under acceleration as if the transmission/clutch for a given car was too weak and slipped, a stab of the clutch would fix it. Other times it just flat out breaks and wont fix until after a restart, and even then sometimes it doesnt work. Really at a loss.
     
  9. Nadeox1

    Nadeox1
    Expand Collapse
    BeamNG.Support
    Staff Member

    Joined:
    Aug 5, 2012
    Messages:
    13,522
    In the second picture here, which one is the clutch?
    Slider? (which looks like closer to 50% than 67%)

    Also, please verify you only have one button/etc from that device is bound to the clutch binding, and if you have extra controllers/devices, disconnect them.
     
  10. -LeveQ-

    -LeveQ-
    Expand Collapse

    Joined:
    May 31, 2015
    Messages:
    10
    Clutch is "Slider" yes, and it does show 50% instead of 67%. It might be due to how I have my clutch setup in-game tho, not linear.

    Clutch input is only set to my pedal, and as far as other controllers, I only have the mouse/keyboard and my shifter.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice