WIP Beta released ETK800 Hybrid 8.0.1

Full hybrid versions of the ETK800 hatchback car

  1. Arcanox

    Arcanox
    Expand Collapse

    Joined:
    Aug 22, 2018
    Messages:
    280
    How doesn't it work? Can you share your log file somehow? I always test my mods as they will be uploaded to the repo (packed up, with nothing else installed in my game) before I release a new version, and the moderators test them as well. All I
    #1 is probably me forgetting to boost the specs; I must have re-copy-pasted a section and forgot to update some values. #2 probably has to do with the throttle curve. Sport mode applies a different throttle curve (internal to the hybrid system, before it gets processed by anything else) so it will see it as a higher "torque request" with the same physical throttle input. I'm not sure how the game handles the "ESC off" mode, but it might keep the same settings as the last "drive mode".
     
  2. default0.0player

    default0.0player
    Expand Collapse

    Joined:
    Nov 30, 2018
    Messages:
    1,746
    This is not easy to explain. In the Hybrid lua controller, it has two values. A" hardware" value that sets the motor power/torque/RPM rating, and a "software" value that sets the "desired" wheel torque/acceleration. This is because power = torque * RPM, as speed goes up, the MG1 slows down and the MG2 speeds up. When in overdrive gear ratio, the MG1 spins backwards, the power is negative. For the sake of handling, the wheel torque/vehicle acceleration must be relatively the same when "shifting", otherwise the vehicle may jerk when MG1 changes direction. Thus, when you apply throttle, what you're actually doing is send acceleration command to the ECU, then the ECU calculate ICE, MG1 and MG2 torque/power, to provide the desired wheel torque. Another thing is when the speed is very low, the motor power is low even the motor torque is high.

    Thus, for constant acceleration. When driving an ICE car with automatic gearbox, apply very little throttle at initial acceleration, and gradually increase throttle as you speed up. When driving a Hybrid or electric car, apply constant throttle from the beginning until you reach desired topspeed.
     
    • Like Like x 1
  3. Arcanox

    Arcanox
    Expand Collapse

    Joined:
    Aug 22, 2018
    Messages:
    280
    Keep in mind there isn't an actual "CVT" as you would find on an ICE car. The main drive motor (MG2) is connected to the final drive through direct gear reduction. The engine and the starter/generator (MG1) are connected to the final drive through a planetary gearset, which essentially has a fixed torque ratio with a varying speed ratio. default0.0player explained it pretty well. Both motors contribute to driving torque (MG1 "sends" the engine torque to the wheels by providing an opposing force), and neither is particularly large, but the whole system together has a pretty good amount of torque (see below for an IRL example). There is always more tuning that I can do to make the system feel better; it's usually what takes the most time and it's something I'm constantly tweaking as I test out the changes I make, so I will probably be able to improve it in the future without any major changes.

    My current car in real life is a 2021 RAV4 Prime, which uses the exact hybrid system design after which I modeled the one I simulate in this mod. It has a 2.5L NA 4-cylinder engine that can produce a measly 177 horsepower. The MG2 motor is rated at 179 horsepower, and the MGR (rear axle) motor is rated at 53 horsepower. The total system output, however is 302, and while there hasn't been an official torque spec released, it's quite high. The eCVT (in direct contrast with a regular CVT or stepped-gear transmission) allows the torque output to be theoretically the same at 100 MPH as it is at 0 MPH, although in reality, motor speed limits and power curves (both of which are simulated in my mod) cause a gradual torque fall off as you get into highway speeds. The ETK856sh specs are closer to what you'd find in a regular RAV4 Hybrid, which means its motors are a bit less powerful than my RAV4 Prime. I'm not sure what the specs are for the stock 6-cylinder engine the game provides, but the engine output is limited by the capabilities of the motors. The rear axle on the AWD versions of the ETK800 Hybrid is a fair bit less powerful than my IRL car, if I recall (don't remember the numbers I decided on off the top of my head), which is why it may seem like it doesn't get a whole lot of torque at the rear wheels compared to a traditional car with a transfer case and driveshaft.
     
    • Like Like x 1
  4. ARES IV

    ARES IV
    Expand Collapse

    Joined:
    May 6, 2019
    Messages:
    417
    Attempted again and did the following:
    • Deleted logfiles.
    • Deep cleared cache
    • Started the game
    • Disabled all mods
    • Closed the game.
    • Started the game
    • Enabled Arcanox Core + ETK800 Hybrid + Hybrid Citybus
    • Closed the game
    • Started the game
    • Started Freeroam West Coast USA with default vehicle being the Eco Hybrid
    • UI gone, no steering or other input possible.
    • Switching vehicle to Vivace = Steering and UI reappear and also work
    • Reset Vehicle
    • Switching to Sport Hybrid
    • Tachometer App reappears but no input is still accepted.
    • Throwing the vehicle with the node graber for brutal damage hundreds of meters away. No damage in the UI app appears.
    • Closing the game with Alt F4












    Log files are attached.

    Thank you for any help. :)
     

    Attached Files:

  5. default0.0player

    default0.0player
    Expand Collapse

    Joined:
    Nov 30, 2018
    Messages:
    1,746
    Another problem with the race hybrid
    When decelerating very rapidly, the powertrain shows significant positive power and the battery drains. Even when wheelslip shuts down the regen, the battery power should still be zero, not power output during deceleration. Please watch this video, especially the last two clips, pay attention to the brake pedal(red bar on the lower-left) and the battery discharge arrow.
     

    Attached Files:

    #365 default0.0player, Nov 10, 2021
    Last edited: Nov 10, 2021
  6. DoritoPowahhhh

    DoritoPowahhhh
    Expand Collapse

    Joined:
    Jan 17, 2021
    Messages:
    223
    how do you switch onto EV mode anyway???
     
  7. default0.0player

    default0.0player
    Expand Collapse

    Joined:
    Nov 30, 2018
    Messages:
    1,746
    Press "E" button
     
  8. Xupaun

    Xupaun
    Expand Collapse

    Joined:
    Aug 18, 2020
    Messages:
    607
    The race hybrid has mismatched final drive ratios too. The front one is 3.23 whle the rear one is 3.93
    --- Post updated ---
    I understand that. I meant to say that it feels CVTish. Also, did some drag race between the Race Hybrid and a non hybrid version of it (simply replaced the eCVT with the 8 speed DCT, the diffs with the standard e-Locking, added the AWD transfercase, and everything else to "remove any trace on the hybrid", but keeping the same ICE and drive ratios, both corrected to be 3.91 on front and back). The results were what I said before. The non Hybrid is faster right of the bat (even broke the tires loose for a second) but the Hybrid quickly catches up and easilly pass (it doest have to shift and it makes, at least, 200 more horsepower).

    When driving the hybrid, against the AI with the non hybrid, I could launch faster some times, but when the electric power really kicks in, the non hybrid loses miserably.

    Maybe the right analogy is: The non hybrid launches like a car with a small turbo and almost no turbo lag, while he Hybrid behaves lke the same car with a gigantic turbo with great turbo lag.
     
  9. Arcanox

    Arcanox
    Expand Collapse

    Joined:
    Aug 22, 2018
    Messages:
    280
    That's intentional; there is no physical connection between the front and rear axles, and the rear motor benefits from a slightly higher final drive ratio because it doesn't have an "internal" gear reduction like the drive motor in the eCVT has. The "ECU" decides on how much torque goes to the rear wheels depending on a number of things. It actually does so more than my real-life car does; my RAV4 is usually fully FWD (rear wheels are just freewheeling) by the time you hit ~20 MPH unless there's some sort of severe front wheel slip going on.

    I'll see if I can figure out why this would be; I'm not sure what caused the regression in low-end immediate torque. I'm not sure when I'll be able to get to it, but I'll make sure I add it to my list :)
    --- Post updated ---
    I'm not quite sure what's going on, but your log files show some game engine script errors that are coming from somewhere other than my mods. They're affecting the hybrid mod (it's looking for something it can't find due to the previous error), but it looks like the source is from an unknown "Driving Dynamics" controller that is corrupted and crashing the game's Lua engine. I don't supply any Driving Dynamics controllers in my mods, so either the game's own code is corrupted and Steam isn't detecting it when you verify, or you have extra files in your user folder somewhere that are being loaded as scripts and crashing something.
     
    • Like Like x 1
  10. default0.0player

    default0.0player
    Expand Collapse

    Joined:
    Nov 30, 2018
    Messages:
    1,746
    How about this sequence:
    • Disable all mods
    • Enable Arcanox Core + ETK800 Hybrid + Hybrid Citybus
    • Close the game
    • Delete temp, lua(if any) and vehicles folder in Windows Explorer
    • Start the game
    --- Post updated ---
    I read the log files, and found that in ARES IV's run, the ETK800 had no exhaust, which in turn disabled the Engine Thermal, since the hybrid mod does not auto-stop when the engine is cold, the lack of thermal broke the hybrid as result.
     
    • Like Like x 2
  11. Xupaun

    Xupaun
    Expand Collapse

    Joined:
    Aug 18, 2020
    Messages:
    607
    Well, about this, when it had mismatched drive ratios, the ICE usually died after some time on "crep mode". The car itself didn't creep smoothly with the mismatched drive ratios (maybe that jolting causes the ICE death), and it also didn't engage the "launch control" everytime. When I put the same drive ratios, the creeping is smooth, the ICE works fine and doesn't die suddenly and the launch control engages everytime I want.

    Remembering that I use the Performace eCVT, with the long range battery.

    Anyways, I still would love to see a hybrid powertrain combined with a multi gear transmission (either DCT or AT), like the germans are doing on their cars, like the Golf GTE (DCT), BMWs with the 30e, 40e and 45e engines (AT), Porsche Panamera Hybrid (DCT) and Cayenne Hybrid (AT).
     
  12. P_enta

    P_enta
    Expand Collapse

    Joined:
    Jan 11, 2020
    Messages:
    3,021
    Auto brake hold should work regardless of the incline, not just if you’re going up a hill.
     
  13. PowerstrokeHD

    PowerstrokeHD
    Expand Collapse
    Banned

    Joined:
    Feb 5, 2021
    Messages:
    2,336
    few bugs I noticed.
    1. Bus for some reason will only work for 15 seconds then it acts like when you get the corrupt core files error message but I don't get the message.
    2. The engine on the ETK 800 will die if you use anything other than the NA 2.0 I4. Even if I just put the turbo onto the engine, it will die.
     
  14. ARES IV

    ARES IV
    Expand Collapse

    Joined:
    May 6, 2019
    Messages:
    417
    Thank you for your attempts at helping me. I appreciate that. Sadly it seems that I am just not supposed to enjoy the Hybrid Mod. Nothing helps. Nothing.

    Deleted the userfolder - doesnt work
    Deleted the entire gamefolder - doesnt work
    Reinstalled the game on a god damm different user brand new windows user account to be certain no leftover files from the past are there.
    Unpacked the mods
    Packed the mods

    The issue persists. I dont understand how I can have corrupt/incorrect files 3 times in a row while reinstalling/verifying that cause just this hybrid mod to make issues. I dont get it and I giving up. :(

    Somehow the combination of my gaming laptop, the game and that particular mod just is not supposed to work for me.

    The UI is corrupted... this is how it looks in a normal car


    and this is how it looks with the Hybrid:




    Attached the entire userfolder after the final attempt.

    Appearantly I am just not granted that particular wish by the digital gods. :mad:
     

    Attached Files:

  15. PowerstrokeHD

    PowerstrokeHD
    Expand Collapse
    Banned

    Joined:
    Feb 5, 2021
    Messages:
    2,336
    The UI is not the Hybrid Mod that is a bug with 0.23.x
     
  16. Arcanox

    Arcanox
    Expand Collapse

    Joined:
    Aug 22, 2018
    Messages:
    280
    What do you mean the ICE "dies"? It's supposed to shut off when not required; that's a key function of hybrids. It will run an initial warm-up cycle and then shut off until you accelerate hard enough, or the battery gets too low. You can creep around on battery power. I'm not sure why the drive ratio would affect anything; the Hybrid controller performs torque calculations taking the "cumulative gear ratio" of both axles into account, so the torque at the wheels will always be what the controller decides it wants, regardless of final drive ratio. The rear final drive ratio will just affect the max torque and speed, since it will affect how fast the rear motor turns and how much torque it needs to output to achieve the desired wheel torque.

    Personally, I'm not a fan of hybrids with shifting transmissions (or even a hybrid with a belt-driven CVT like Honda used to make). Shifting feels intrusive to me after having driven a Toyota hybrid, then a Volt, then another Toyota hybrid as my daily car IRL. I have plans to make my hybrid simulation more modular so that something like a DCT- or AT-coupled hybrid would be possible, but I'm not sure if I'll ever make a version like that myself.

    Is there anything yellow or red in the game console after the bus "crashes" like you described? That's sort of ambiguous, I don't know what could cause something like that. With regards to the ETK, the "Race Hybrid" version has a turbo installed by default and it works fine. Again, does the game log any sort of warning or error (yellow or red text) in the game console when this happens?
     
    • Like Like x 1
  17. PowerstrokeHD

    PowerstrokeHD
    Expand Collapse
    Banned

    Joined:
    Feb 5, 2021
    Messages:
    2,336
    The ICE fails. You know how when you run out gas in game it will say "Engine Disabled". That happens here. I also get a message in the message center saying "Engine failed, Propulsion Power Reduced"
     
  18. Arcanox

    Arcanox
    Expand Collapse

    Joined:
    Aug 22, 2018
    Messages:
    280
    Are you able to get video of this happening by any chance? That typically only happens when the engine is physically damaged; I detect when that happens and display the second message, but the "Engine Disabled" message comes from BeamNG itself. The rear axle has no physical connection or relation to the engine at all, so I'm still very confused as to how the rear final drive ratio could have any bearing on the engine being damaged.
    --- Post updated ---
    I think I finally might have figured out what is going on. I took a closer look at your log file and noticed one thing that led me on the right path. It looks like you have your default gearbox mode set to "Arcade" and not "Realistic". Normally, any of the hybrid vehicles will override that to "Realistic" because the hybrid eCVT gearbox does not support Arcade mode for a number of reasons. It looks, however, like BeamNG changed the order of initialization in 0.22 or 0.23, and now the code that tries to override it to "Realistic" crashes due to it not finding the thing it needs from the base game. The original logs you posted showed another error before that which led me on the wrong path, as the first error was actually due to a built-in controller crashing during initialization, sort of "hiding" the original problem. I will try and find time soon to submit a patch for the Core mod to fix the underlying issue so that Arcade mode doesn't crash it any more. In the meantime, if you set the game's default gearbox mode to Realistic in the Gameplay settings, it should work fine. I always forget that "Arcade" even exists, so I never think to try changing that setting.
     
    • Like Like x 2
  19. ItsTheLittleAcura!

    ItsTheLittleAcura!
    Expand Collapse

    Joined:
    Feb 9, 2018
    Messages:
    114
    My G1 Prius has a 1:1 MG2 to drive gear relationship, rather than the newer design reduction-gear system. With launch control (holding full throttle against the brakes, and popping off the brakes to go) peak torque as quoted by Toyota is 300+ lb-ft from 0-400 rpm (MG2 makes 260 on its own, plus what the ICE can contribute.) I've done a launch-control start a couple of times, it's surprisingly fun. "Eat my voltage" (the original slogan for the G1 Prius) is 100% correct.
     
  20. ARES IV

    ARES IV
    Expand Collapse

    Joined:
    May 6, 2019
    Messages:
    417
    Bull's eye! Switching back to realistic gearbox mode makes the vehicle act normal again. Ironically my agressive attempts at getting the debug app to work probably made things worse as I deleted all settings, thus causing an revert to Arcade gearbox inadvertently.

    The vehicle now works. What still - at least for me - doesnt work is vehicle keys (cannot switch to EV mode for example, pressing E does nothing) and the Arcanox Debug App.







    Thank you for your support. At least I can drive it now. ;)
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice