1. Intel iGPU (6xx series) crashes
    Fixed drivers available!
    Instructions here

    Dismiss Notice
  2. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    0.20 Bug Reporting thread
    Solutions and more information may already be available.

extremely slow ui

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by nightdrive889, May 25, 2019.

  1. nightdrive889

    nightdrive889
    Expand Collapse

    Joined:
    May 25, 2019
    Messages:
    1
    all mods were disabled
    any help would be appreciated
     

    Attached Files:

  2. Nadeox1

    Nadeox1
    Expand Collapse
    Administrator
    BeamNG Team

    Joined:
    Aug 5, 2012
    Messages:
    14,718
    Your framerate looks unstable already.
    If performance is lacking, the UI is the first thing to suffer from it, since it has lower priority.
    Although that's quite exaggerated in the video.

    Try enabling 'Hardware Acceleration for User Interface' in Options > Graphics.
    It's experimental, while it works for most people, for some particular setups it could cause issues.

    If you have it already enabled, then disabled it.
    You must restart the game to apply it.
     
  3. lukethomasgardiner

    lukethomasgardiner
    Expand Collapse

    Joined:
    Oct 26, 2015
    Messages:
    3
    I have been having the exact same issue as well for ages.
    System specs:
    i7 6700
    GTX 1050
    8GB DDR4 2133mhz
    As far as I can tell its an optimization issue? When I have 1 car loaded cpu usage is minimal at around 30% on the same map so theres plenty of head room. But the ui seems to take ages to load and I have to pause physics for it to speed up. It doesn't seem to be a physics bottle neck either because I checked the timings on the performance graph and it seemed alright? Gpu is at full load as well.
     
  4. fufsgfen

    fufsgfen
    Expand Collapse

    Joined:
    Jan 10, 2017
    Messages:
    7,046
    You can have CPU load as 30% while your CPU is maxed out, not everything can be threaded and games quite often are not threaded like rendering in Blender which can utilize all CPU cores to maximum. BeamNG is not even worst in this.

    I have experimental UI acceleration enabled without issues, UI is instant fast.

    I used to have similar specs of yours, but 16GB of faster ram and 1050Ti, limiting fps to 60 by fps limiter or vsync, playing ssao and reflections off and normal graphics was perfectly fluent pretty much anywhere else than Italy main city. UI was not very laggy at all.

    Also if you have Windows 10, turn game mode off, that just is not compatible with any game that uses separate process for UI.
     
    • Like Like x 1
    • Informative Informative x 1
  5. lukethomasgardiner

    lukethomasgardiner
    Expand Collapse

    Joined:
    Oct 26, 2015
    Messages:
    3
    I'm pretty sure its not a CPU nor ram issue, and I also have hardware acceleration on with medium settings and ssao off. not sure why I'm getting issues. I do know that the games physics isn't overloading the CPU (no drop in simulation speed either) so the ui wouldn't be effected. could be that the ui is separate process?
     
  6. fufsgfen

    fufsgfen
    Expand Collapse

    Joined:
    Jan 10, 2017
    Messages:
    7,046
    Make sure you check CPU load of each core, select logical processors from task manager, but then again task manager can show only 60% on one core that is maxing out.

    However if your FPS is not dropping, your game runs fine, but only UI is lagging behind, then that is likely to be related to process priority, which Windows 10 messes up with it's game mode, well that is if you are running windows 10 in first place.

    I'm running last Nvidia driver before RTX lineup support, that is version 399.07 and performance is great, everything works, except Steam's overlay (even with overlay disabled Steam loads overlay) and BeamNG in my Windows 8.1 installation, UI crashes, but running outside of Steam is fine.

    There has been trouble with latest Nvidia drivers too, not sure if this old version will help though, nobody has not had courage to test yet, I guess. With newer driver I had higher GPU load, up to 20% difference on gtx1080.

    Physics are quite light indeed, it is more of combination of graphics, lua, etc.

    Also there was at least one recent Nvidia driver version which did use a lot of single core performance of CPU that made things slow for most.

    Issues with UI performance are odd in there that seemingly there is no pattern to it, for some it might be that GPU vram runs out, should not happen at Gridmap though, but for example at Italy it could happen if 2GB model of GPU, I have seen around 4GB usage with 1050Ti and with gtx1080 vram usage is around 5GB for no sane reason.


    If you have some game accelerator, those can mess up with UI performance too as they do same as game mode of Windows 10, they change process priority.

    So when Beamng gets higher priorty than UI process and BeamNG uses hardware heavily, UI will wait more doing nothing.

    That is why process priority of both, BeamNG and UI process needs to be normal, but any game booster/accelerator or Win10 game mode changes BeamNG to high and others to low or something like that, balance is lost and UI starts then lagging.

    For any game to run best possible way, it needs to have bit less than maximum load on any of the CPU cores/threads. Except Cities Skylines, that is just poor optimizations, it will lag with any hardware.
     
    • Like Like x 1
  7. lukethomasgardiner

    lukethomasgardiner
    Expand Collapse

    Joined:
    Oct 26, 2015
    Messages:
    3

    Thanks for replying
    I can confirm that game mode is off and I am running on windows 10, I had a look at task manager and resource monitor, and I can see that the most of the CPU load is spread across all 8 threads. I had a look at the details options had a look at the set priority they were both on normal so i changed the ui to high priority and so far it seems to have sped it up quite a bit. not sure whether its a long term fix but it seems to be working
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice