1. Issues with the game?
    Check the Known Issues list before reporting!

    Dismiss Notice

Gears Shifting up 2 at a time?

Discussion in 'General Discussion' started by GTS250GAMER101, Jul 6, 2019.

Tags:
  1. GTS250GAMER101

    GTS250GAMER101
    Expand Collapse

    Joined:
    Nov 14, 2017
    Messages:
    1
    Hello all,

    I have been playing a lot of BeamNG.drive lately, and have noticed that while shifting up on my steering wheel, the gears sometimes go up 2 at a time, in manual or automatic. This is only when upshifting, and it's only recently been a problem.

    For example, in a manual, it would go from neutral to 2nd gear, and on an automatic, it would go from neutral to 2(L).

    Any help would be much appreciated! Thanks all!!
     
    • Agree Agree x 2
  2. LucasBE

    LucasBE
    Expand Collapse

    Joined:
    Mar 22, 2015
    Messages:
    2,122
    Maybe the buttons on your steering wheel have a problem and click twice instead of once?
     
  3. Sithhy™

    Sithhy™
    Expand Collapse

    Joined:
    Apr 5, 2017
    Messages:
    3,303
    Does it happen each time you connect the steering wheel? I know that sometimes my controller does this because something messes up between BeamNG & the controller program which makes the act as two inputs at once. It's weird, but maybe your steering wheel software breaks something?
     
  4. [SP] - Yukels

    [SP] - Yukels
    Expand Collapse

    Joined:
    Jul 6, 2017
    Messages:
    1
    I have the same problem and I'm pretty sure it's a problem with my hardware. It often doesn't just shift two gears but up to four per button press. Other games like Dirt Rally have a short cooldown between button inputs so that's no problem there. So I was wondering if any such "cooldown" could be activated in the settings of BeamNG..?
     
  5. Alex_Farmer557

    Alex_Farmer557
    Expand Collapse

    Joined:
    Dec 28, 2016
    Messages:
    3,534
    Not that i know of, and it was not necessary to reply to this thread.
     
  6. jakelooker

    jakelooker
    Expand Collapse

    Joined:
    Aug 31, 2013
    Messages:
    136
    This seems like a perfectly reasonable message to reply to this thread rather than starting a new one. I'm not in front of the game right now but these options are normally referred to as "debounce". If you check the advanced options for your shifter bindings you may be able to enable it. If not, this would be great for the devs to implement @Nadeox1
     
    • Like Like x 1
  7. wagonheart

    wagonheart
    Expand Collapse

    Joined:
    Feb 7, 2020
    Messages:
    1
    Im also having this issue, but im on controller, does the same on both xbox 360 wired controller and PS4DS with DS4Windows, unable to find any settings to change this
     
  8. Sithhy™

    Sithhy™
    Expand Collapse

    Joined:
    Apr 5, 2017
    Messages:
    3,303
    Use the controllers wirelessly, or in DS4Windows go into Settings & enable "Quick Charge" which will then cut the Bluetooth connection when you're connected through the USB cable
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice