1. Intel iGPU (6xx series) crashes
    Fixed drivers available!
    Instructions here

    Dismiss Notice
  2. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    0.20 Bug Reporting thread
    Solutions and more information may already be available.

I have a question about menu

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by Exchy, May 29, 2019.

  1. Exchy

    Exchy
    Expand Collapse

    Joined:
    Aug 27, 2016
    Messages:
    218
    First, I do have a reshade and yes it lags horribly in menu I know because of reshade even without GPU as a renderer. What's strange that it "lags horribly" if launch in normal mode with mods. But the thing is, in safe mode I can simply activate all mods and no lag appears. What is the real difference between normal and safe launch anyway. Thanks
     
  2. Nadeox1

    Nadeox1
    Expand Collapse
    Administrator
    BeamNG Team

    Joined:
    Aug 5, 2012
    Messages:
    14,718
    Can't help with ReShade, since it's a third-party program hooking into the game and doing it's own things.

    Your UI performance may be related to the Options > Graphics > 'Hardware Accelerated User Interface' setting.
    This is an experimental feature, and while it works fine for most users, on particular setups it can have some problems (not evening mentioning ReShade and similar).

    Try toggling it. You must restart the game for the change to apply.

    Safe Mode by default disables it, so that's why you are getting no lag with it.
     
  3. Exchy

    Exchy
    Expand Collapse

    Joined:
    Aug 27, 2016
    Messages:
    218
    Ok so If I want it off without reshade, I can't seem to find any line regarding hardware or ui render in game-settings-ini. Just in .cs file I have this "$pref::Video::disableHardwareAA = 1;"
     
  4. CN877

    CN877
    Expand Collapse

    Joined:
    Jun 27, 2017
    Messages:
    1,690
    It's just an option in the game settings. Just uncheck 'enable hardware acceleration for UI'
     
    • Agree Agree x 1
  5. Nadeox1

    Nadeox1
    Expand Collapse
    Administrator
    BeamNG Team

    Joined:
    Aug 5, 2012
    Messages:
    14,718
    It's uiAcceleratedRender in "games-settings.ini", but as said above, the setting is in-game in the Graphics menu.
     
    • Agree Agree x 1
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice