1. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    Solutions and more information may already be available.

I'm having driveshaft issues...

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by Kefko, Feb 26, 2020.

  1. Kefko

    Kefko
    Expand Collapse

    Joined:
    Oct 29, 2019
    Messages:
    10
    I am trying to create a hyper-light SBR4, and for the most part, succeeding. Or so i thought. I take a couple test runs and then realize that, rarely, seemingly randomly, my driveshaft would snap like a toothpick. As more testing went on, this problem became more and more frequent, and is now basically guaranteed. Sometimes it happens at about 80mph, sometimes I cant even get off the line. Any ideas on how to preserve this thing so i can get back to 311mph on straights?
     
  2. torsion

    torsion
    Expand Collapse

    Joined:
    May 31, 2015
    Messages:
    1,622
    Try using slow motion to look for the issue. Use the debug menu or keyboard shortcuts to turn on beam visualization. You may have adjusted the nodeWeight without a corresponding adjustment to other parameters (beam spring/damp). That can lead to oscillations/shaking - weight and spring/damp get adjusted together. Driveshaft breakage is normally due to exceeding a length bound.

    Maybe take a look here: https://wiki.beamng.com/JBeam_Physics_Theory
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice