Introduction to scenarios creation

Discussion in 'Content Creation' started by Nadeox1, Jul 14, 2015.

  1. Scepheo

    Scepheo
    Expand Collapse

    Joined:
    Feb 10, 2015
    Messages:
    601
    scenario_player0
     
  2. Regenworm

    Regenworm
    Expand Collapse

    Joined:
    Feb 6, 2016
    Messages:
    197
    Yes that one i mean. How to get the scenario_player0 codes of a car. like the JBEAM " Hatch " thing and stuff in the json file. How can i get those things for the Sunburst Rally?
    --- Post updated ---
    oh and how to post your scenario on BeamNG.com?
     
  3. sharkdidit

    sharkdidit
    Expand Collapse

    Joined:
    Mar 27, 2016
    Messages:
    9
    I am getting a black screen and no saved .prefab file when I get to the Pack Prefab step. After I select the filename to save on the Desktop, the camera goes black and no file is saved on the desktop.

    BeamNG_Editor_BlackScreen_my_first_scenario_prefab_pack.JPG

    beamng.log

    If there is any other information I can provide, please let me know.

    Best regards,
    Tony
     

    Attached Files:

  4. Nadeox1

    Nadeox1
    Expand Collapse
    Spinning Cube
    BeamNG Team

    Joined:
    Aug 5, 2012
    Messages:
    14,654
    Log says:
    178.52905|E|Prefab::_loadFile|Prefab::_loadFile() - file C:/Users/Tony/Desktop/my_first_scenario.prefab was not found.

    Not sure how are you saving
     
  5. sharkdidit

    sharkdidit
    Expand Collapse

    Joined:
    Mar 27, 2016
    Messages:
    9
    I am saving exactly per the instructions at the beginning of this thread, where it says "After that, you can Repack your prefab like shown in the picture:" I presume the "not found" failure is because this step is failing for some reason and it is not saving.
     
  6. Nadeox1

    Nadeox1
    Expand Collapse
    Spinning Cube
    BeamNG Team

    Joined:
    Aug 5, 2012
    Messages:
    14,654
    Yeah, probably.
    Nothing much I can do to help you, as I'm limited to watching only your log and not what you have done exactly.

    I suggest to make sure you aren't missing any points.
    Also, perhaps try a different name or something, or make sure the game has access to that folder.
     
  7. Scepheo

    Scepheo
    Expand Collapse

    Joined:
    Feb 10, 2015
    Messages:
    601
    Read better:
    Shit, the emphasis isn't even mine.
     
  8. sharkdidit

    sharkdidit
    Expand Collapse

    Joined:
    Mar 27, 2016
    Messages:
    9
    I don't know what your problem is, but you don't seem to understand what I am telling you.

    The directory 'Documents/BeamNG.Drive/Users/yourname/Desktop' does not even exist. The prefab file does not exist.

    Sheesh.
     
  9. Nadeox1

    Nadeox1
    Expand Collapse
    Spinning Cube
    BeamNG Team

    Joined:
    Aug 5, 2012
    Messages:
    14,654
    Try to save it in Documents/BeamNG.Drive from the editor then, not on the Desktop.
     
  10. sharkdidit

    sharkdidit
    Expand Collapse

    Joined:
    Mar 27, 2016
    Messages:
    9
    After poking around in directories, I found this:

    It is not saving to 'Documents/BeamNG.Drive/Users/yourname/Desktop' as the instructions state above
    it is saving to 'Documents/BeamNG.Drive/content/Users/yourname/Desktop'
     
  11. MilesLexicon

    MilesLexicon
    Expand Collapse

    Joined:
    Jan 18, 2016
    Messages:
    53
    After I move the car into position and pack it, I save it to .prefab in my desktop, and it deletes the car, please help.
     
  12. Scepheo

    Scepheo
    Expand Collapse

    Joined:
    Feb 10, 2015
    Messages:
    601
    Spawn a new car ("clone0" instead of "thePlayer") and use that.
     
    • Like Like x 1
  13. MilesLexicon

    MilesLexicon
    Expand Collapse

    Joined:
    Jan 18, 2016
    Messages:
    53
    Sorry, I'm rather new at this, how would that be done?.
     
  14. Scepheo

    Scepheo
    Expand Collapse

    Joined:
    Feb 10, 2015
    Messages:
    601
  15. crazikyle

    crazikyle
    Expand Collapse

    Joined:
    Sep 3, 2013
    Messages:
    808
    So I've finally hit a development dead end in that I can't get the AI to follow a path. I've seen some people with similar problems, yet there is no solution that I can find. I have 8 waypoints, and a decal road for the AI to follow. I'm using @Scepheo race script, and so far the race will start, the AI will begin driving but will get confused and turn around and go back and forth between points. I cannot figure out why this is happening. They seem to ignore both the checkpoints and the decal road. If need be I can give you the scenario file. I just need someone to point me in the right direction, thanks.
     
  16. Nadeox1

    Nadeox1
    Expand Collapse
    Spinning Cube
    BeamNG Team

    Joined:
    Aug 5, 2012
    Messages:
    14,654
    I suggest to wait for the next update. Some AI refactoring should be un there, changing some logic and hopefully solving your issue. I had the same issue when making the intersection scenarios, it's kinda random.
     
  17. Aerotactics

    Aerotactics
    Expand Collapse

    Joined:
    Dec 23, 2015
    Messages:
    57
    How do you change the date in the kit? It looks like some number, but how do you get it?
     
  18. Scepheo

    Scepheo
    Expand Collapse

    Joined:
    Feb 10, 2015
    Messages:
    601
    It's a Unix timestamp.
     
  19. Aerotactics

    Aerotactics
    Expand Collapse

    Joined:
    Dec 23, 2015
    Messages:
    57
    Thank you!
     
  20. Destroyer247_52

    Destroyer247_52
    Expand Collapse

    Joined:
    Mar 9, 2015
    Messages:
    188
    What is the difficulty number for hard? I know easy and medium but I would like to know the number for hard. Also what is the are the date numbers?
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice