1. Stuck, Having problems with creating your mod? Let us help you: Mod Support

Introduction to Vehicle Creation - Feedback Thread

Discussion in 'Content Creation' started by B25Mitch, Nov 26, 2014.

  1. TWilliams458

    TWilliams458
    Expand Collapse

    Joined:
    Aug 26, 2016
    Messages:
    449
    Time for me to try and begin modding. First car I will make

    Mazda RX3. But I need to learn first :)
     
  2. WamboGT

    WamboGT
    Expand Collapse

    Joined:
    Jun 29, 2017
    Messages:
    1
    Alright I've been at this a couple days, and my N/B refuses point blank to show up in game. http://puu.sh/wwVo1/f88652672f.zip
    If anyone can figure out what is wrong with it (structure, export, a bracket somewhere) I will pay them with melons or something...
    --------UPDATE-----
    after changing literally nothing, it works now...... computers
     
    #182 WamboGT, Jun 29, 2017
    Last edited: Jun 29, 2017
  3. nastygdigger

    nastygdigger
    Expand Collapse

    Joined:
    Mar 19, 2015
    Messages:
    629
    Let me guess. this is outdated?
     
  4. Gavril T85

    Gavril T85
    Expand Collapse

    Joined:
    Aug 14, 2017
    Messages:
    667
    I am aware that this a pretty big bump, but I'd really like to get help. When I turn the wheels, both wheels turn inward or outward, and I don't know what the problem is. Here's the code:
    Untitled.png (ignore the negative lock degree values, they didn't change anything.)

    what.gif
    Any help would be appreciated :)
     
  5. Gavril T85

    Gavril T85
    Expand Collapse

    Joined:
    Aug 14, 2017
    Messages:
    667
    Thanks!
    --- Post updated ---
    Now the wheel mesh won't work for me, someone have any ideas/help?
    screenshot_00012.png
    materials.cs
    Untitled.png

    bus_wheel.png
    bus_wheel.png

    flexbody Jbeam
    dddd.png

    .dae
    Untitlesd.png
     
  6. Gavril T85

    Gavril T85
    Expand Collapse

    Joined:
    Aug 14, 2017
    Messages:
    667
    The bus spawns like that, even if I reset it while physics are paused. I think it's a mesh/material problem. Here's the Jbeam anyways, I'm pretty sure everything's correct:
     

    Attached Files:

  7. Gavril T85

    Gavril T85
    Expand Collapse

    Joined:
    Aug 14, 2017
    Messages:
    667
    here
     

    Attached Files:

  8. Gavril T85

    Gavril T85
    Expand Collapse

    Joined:
    Aug 14, 2017
    Messages:
    667
    Thanks again!
     
  9. .nokau

    .nokau
    Expand Collapse

    Joined:
    Mar 20, 2018
    Messages:
    50
    I've followed the tutorial and so far I've made this using the unpacked mod method, it feels like once the base nodes and beams is there, it's more about figuring out how to connect nodes together and give mesh proper node groups to follow, am I getting this right?
    screenshot_00000.png problem02.png
    I also got some problems
    I couldn't figure out why the texture isn't loading, I think I've got my material named.
    Engine and transmission is there but no power deliver to the wheels
     

    Attached Files:

    #189 .nokau, Mar 21, 2018
    Last edited: Mar 21, 2018
  10. Gavril T85

    Gavril T85
    Expand Collapse

    Joined:
    Aug 14, 2017
    Messages:
    667
    You named the materials.cs file meterial.cs. Rename it to materials.cs, BeamNG is very case sensitive.
     
  11. .nokau

    .nokau
    Expand Collapse

    Joined:
    Mar 20, 2018
    Messages:
    50
    ooo, thanks didn't notice that, but the texture still won't show up though.

    Update: I added a folder and put both the .cs and texture in it, it's working now:D
     
    #191 .nokau, Mar 22, 2018
    Last edited: Mar 23, 2018
    • Like Like x 1
  12. danielgreenfield0

    danielgreenfield0
    Expand Collapse

    Joined:
    Sep 27, 2016
    Messages:
    9

    Hi I'm new to blender and I've been trying to figure out the jbeam export section of the wiki. I have the export tool installed and there doesn't seem to be an option to export the jbeam file. I don't know what i'm missing.
     
  13. 1402News

    1402News
    Expand Collapse

    Joined:
    May 14, 2018
    Messages:
    2
    Can someone tell me how to add vertices?
     
  14. losr

    losr
    Expand Collapse
    Banned

    Joined:
    Sep 15, 2016
    Messages:
    191
    duplicate another vertex from the same mesh then connect edges or faces to it
     
    • Informative Informative x 1
  15. 1402News

    1402News
    Expand Collapse

    Joined:
    May 14, 2018
    Messages:
    2
    I don't get it.
     
  16. losr

    losr
    Expand Collapse
    Banned

    Joined:
    Sep 15, 2016
    Messages:
    191
    In edit mode (if you're using Blender), select a single vertex on your mesh, then do SHIFT+D to duplicate that vertex. Once it's duplicated you can connect other edges and faces to it.
     
    • Informative Informative x 1
  17. mehio

    mehio
    Expand Collapse

    Joined:
    Jun 20, 2018
    Messages:
    54
    ive followed the steps up until making the "info.json " file so that the car shows in the vehicle selector but it doesnt show.
     
  18. RX7 dorifto

    RX7 dorifto
    Expand Collapse

    Joined:
    Oct 7, 2017
    Messages:
    1
    Hi! I have a problem - my car doesn't show up in the vechicle selector, and i dont know what should i do. I followed the steps to making the info.json file and... I don't have my car. In game, i only see a weird "unknown" car, when i spawn it, this shows up... (1st screenshot) And i also attach looks of my folder and all the files.
    . 2018-08-311.png 2018-08-312.png
     

    Attached Files:

  19. Teh Daemon

    Teh Daemon
    Expand Collapse

    Joined:
    Aug 4, 2013
    Messages:
    52
    Hi, I've been trying to get the engine to work for the car I'm making, but it just refuses to start. I initially copied the engine data from the tutorial, but after that didn't work I tried using the powertrain stuff. Here's the relevant section of my jbeam:

    Code:
    "controller": [
            ["fileName"],
            ["vehicleController", {}],
        ],
       
        "powertrain": [
            ["type", "name", "inputName", "inputIndex"],
            ["combustionEngine", "mainEngine", "dummy", 0],
        ],
        "mainEngine": {
            "torque":[
                ["rpm", "torque"]
                [0,       0],
                [500,    85],
                [1000,  102],
                [1500,109.5],
                [2000,  122],
                [3000,  145],
                [4000,  159],
                [5000,159.5],
                [6000,  152],
                [7000,  121],
                [7500,   74],
                [8000,   44],
                [9000,   34],
            ],
     
            "idleRPM":1000,
            "maxRPM":6700,
            "inertia":0.08,
            "friction":12,
            "dynamicFriction":0.022,
            "burnEfficiency":[
                [0, 0.12],
                [0.05, 0.26],
                [0.4, 0.42],
                [0.7, 0.47],
                [1, 0.35],
            ],
            "torqueReactionNodes:":["nr43", "nr35", "nr47"]
            "uiName":"Engine",
            //transmission section
            "transmissionType":"manual", //Automatic or manual, setting automatic will restrict the use of manual mode while playing.
            "lowShiftDownRPM":1400,
            "lowShiftUpRPM":3600,
            "highShiftDownRPM":3300,
            "highShiftUpRPM":6000,
            // -1, 0 (neutral), 1, etc
            "gears":[-2.9, 0, 26.5, 13.25, 8.82, 6.625] //Gear ratios
            "clutchDuration":0.25
            "viscousCoupling":3.5
            "lockingTorqueLimit":150
            "enableLocking":true
    },
       
        "vehicleController": {
            "lowShiftDownRPM":1400,
            "lowShiftUpRPM":3600,
            "highShiftDownRPM":3300,
            "highShiftUpRPM":6000,
        },
    I tried pressing V to start the car, and also tried pressing Q to switch between arcade and sim. Nothing seems to work though.

    EDIT: I got a basic powertrain set up after following this page https://wiki.beamng.com/Powertrain . It appears this guide is very outdated and uses an old format for engines for anyone else wondering.
     
    #199 Teh Daemon, Sep 3, 2018
    Last edited: Sep 5, 2018
  20. GlendaleDrift!?!?!

    GlendaleDrift!?!?!
    Expand Collapse

    Joined:
    Jun 19, 2018
    Messages:
    37
    i love this tutorial, but can you make a tutorial on how to make custom models for cars that are already in the game?
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice