1. Issues with the game?
    Check the Known Issues list before reporting!

    Dismiss Notice
  2. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    0.25 Bug Reporting thread
    Solutions and more information may already be available.

Strange textures when combining vehicles/materials

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by wrinkle345, Jul 21, 2016.

  1. wrinkle345

    wrinkle345
    Expand Collapse

    Joined:
    Jul 2, 2015
    Messages:
    546
    While working on a type of combination of the Roamer and the D15, I hit a little snag.

    screenshot_00010.png screenshot_00011.png

    It's almost like both materials couldn't decide on what material to use.

    Originally, I had the UVs of the Roamer-half be scaled to 0 and just placed somewhere in the pickup's uv so that the colors would be the same. But normal maps and such were of course also lost, so I went back to the original UV. But now this happens. Any ideas on fixing this?
     
  2. Nadeox1

    Nadeox1
    Expand Collapse
    Spinning Cube
    BeamNG Team

    Joined:
    Aug 5, 2012
    Messages:
    14,657
    Looks like the UV does not match the texture.
    Double check them in Blender / Whatever you use.
     
  3. wrinkle345

    wrinkle345
    Expand Collapse

    Joined:
    Jul 2, 2015
    Messages:
    546
    It appears to be that exact problem. It seems the UVs were out of order; the "Skinable" UV layer was getting the normal textures while the "Normal" UV layer was taking the skins. I changed their order and it seems to have fixed it for the most part.

    Thank you for the help/advice. ^^
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice