1. Intel iGPU (6xx series) crashes
    Fixed drivers available!
    Instructions here

    Dismiss Notice

Traction control and ABS brakes

Discussion in 'General Discussion' started by fufsgfen, Dec 3, 2019.

  1. fufsgfen

    fufsgfen
    Expand Collapse

    Joined:
    Jan 10, 2017
    Messages:
    7,046
    So I did set ESC pretty much disabled, set TC to not cut throttle and had hopes of getting TC to brake, but it does not, maybe it is not designed not to.

    But if I apply brakes before throttle I get normal braking, but if I apply brakes after throttle I get pretty much what I think is TC activating brakes:


    It was more clear when doing hanging from corners thing, but I'm not 100% certain that it is not ESC doing the brakes thing.

    Anyone has a manual for this ESC/TC parameters thing? can't find much.

    Anyway I don't know why it matters at which order brake and throttle is applied or if thing is working as it should, there are brake parameters in TC section, but not sure what those are either and trial / error is not providing to be too useful.
    --- Post updated ---
    Oh wait, after turning ESC and TC off I still had the same, it is just the ABS behaving differently if brakes are applied while there is wheelspin thing.

    ABS can go to 0 brake force on all brakes for long time sometimes.


    ABS is quite useful in this situation though, but one need to have wheelspin first, ABS is not updating itself constantly, only when triggered by some things:
     
    #1 fufsgfen, Dec 3, 2019
    Last edited: Dec 3, 2019
    • Like Like x 1
  2. fufsgfen

    fufsgfen
    Expand Collapse

    Joined:
    Jan 10, 2017
    Messages:
    7,046
    I don't get this ABS, in different situations there is different amount of throttle that makes it act different way, say around 30% throttle with Sport Roamer in these situations and ABS acts more intelligent way trying to brake faster spinning rear tires, but when front tires are faster spinning it just gives up, brake force 0 until something jolts it back to senses:


    However give more throttle or less throttle and it is not doing that.
     
  3. fufsgfen

    fufsgfen
    Expand Collapse

    Joined:
    Jan 10, 2017
    Messages:
    7,046
    Issue with 0.17 TCS seems to be that it has been tuned to very low slip threshold with some vehicles. Default value for kc6t is 0.02 and even with value of 0.07 there is not too much of wheelspin:
    upload_2019-12-8_2-29-20.png

    Also ESC seem to be active mostly in oversteer conditions, but for understeer it seems not to care much, no matter how much you turn wheels it is not helping car to turn, well most of the time, sometimes it does, but desired yaw as well and as result difference seems to indicate that only oversteer is countered by ESC.

    However there is so many parameters that I have no idea that I have no idea if it is by how parameters are set or if it is designed way ESC works.

    At times though, I have managed to get ESC and TCS work pretty nicely, however especially with kc6t TCS is sometimes too liberate, allowing much more slip before really taking control and I guess to counteract that value has been set so low as 0.02, would that be 2% slip?
     
  4. default0.0player

    default0.0player
    Expand Collapse

    Joined:
    Nov 30, 2018
    Messages:
    811
    In order to solve the problem you need to increase the maxSideAcceleration
    In this example, the etkc_esc.jbam open this file and
    Code:
                        "maxSideAcceleration":10,
    Change the 10 to 20 or higher
     
    • Informative Informative x 1
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice