1. Before reporting issues or bugs, please check the up-to-date Bug Reporting Thread for the current version.
    Solutions and more information may already be available.

Vehicle specific key binds not saving

Discussion in 'Troubleshooting: Bugs, Questions and Support' started by jec0218, Apr 17, 2019.

  1. jec0218

    jec0218
    Expand Collapse

    Joined:
    Apr 17, 2019
    Messages:
    4
    When i open the vehicle specific key bind tab in controls it deletes all of the key binds and then when i try to make a new key bind it does not save when i press apply. FWI all mods are deactivated. Please help
     
  2. cln_ellison

    cln_ellison
    Expand Collapse

    Joined:
    Jan 12, 2018
    Messages:
    1
    I am having this issue as well. (trying to regain use of the tseries rollback). anybody else ever have this issue?
    Ive tried: deactivating all mods, uninstall game and reinstall, and verifying steam files.
     
  3. stenyak

    stenyak
    Expand Collapse
    Staff Member

    Joined:
    Aug 6, 2012
    Messages:
    1,152
    This typically happens when BeamNG.drive is denied permissions to write files to disk.

    This can happen with badly configured folder permissions (in documents/beamng.drive), overprotective antivirus configuration, or any incompatible third party software you may be using: https://wiki.beamng.com/Incompatible_Third_Party_Software
     
  4. fufsgfen

    fufsgfen
    Expand Collapse

    Joined:
    Jan 10, 2017
    Messages:
    6,795
    Also Windows 10 has some folder access management that can cause issue, I have seen people with other games having issues with that feature.
     
  5. jec0218

    jec0218
    Expand Collapse

    Joined:
    Apr 17, 2019
    Messages:
    4
    I checked and this is not the case
     
  6. stenyak

    stenyak
    Expand Collapse
    Staff Member

    Joined:
    Aug 6, 2012
    Messages:
    1,152
    Alright, please send a support report so I can take a look :)
     
  7. jec0218

    jec0218
    Expand Collapse

    Joined:
    Apr 17, 2019
    Messages:
    4
    ok i will send one very soon
     
  8. jec0218

    jec0218
    Expand Collapse

    Joined:
    Apr 17, 2019
    Messages:
    4
    53908
     
  9. stenyak

    stenyak
    Expand Collapse
    Staff Member

    Joined:
    Aug 6, 2012
    Messages:
    1,152
    I see nothing wrong in the logs. Taking the T-series semi truck as an example, according to the logs, you added the 'Y' key binding, and removed the rest of them. Can you please record a video with that specific vehicle, attempting to add another vehicle-specific key to it?
    I'm unable to reproduce any issues, all bindings save correctly for me, so it would be helpful to see what exactly you are doing. Thanks!
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice